AVS Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
So I bought a new Samsung LN52A550 last week, hooked up the PS3 and the digital cable box, and everything has been fine. Until tonight, when all of a sudden the picture changed to look crazy, with red outlines everywhere. First I thought it was the cable TV signal, but the same effect occurred with DVDs and the Playstation. Turning the unit off and on had no effect. Thinking that maybe there was a bad cable that was shorting out the TV, I unplugged all cables except the HDMI from the PS3 and turned everything back on, but the problem remained. However, after about 20 seconds the picture came back and it hasn't malfunctioned since.


Any ideas what's going on here? Could a faulty cable short something out to cause this sort of thing? Could a faulty cable TV box damage the TV? Or did I just maybe get a bad unit?


Does anyone have any advice about getting a replacement? I could probably return it to Circuit City. Otherwise, I was wondering if Samsung replaces faulty units with refurbished ones (obviously, I'd prefer a brand new unit). Anyway, kind of a weird effect, isn't it?


Here's a photo from a cable TV channel



This shows it's the display and not just a red source



Thanks!
 

·
Registered
Joined
·
6,908 Posts
Swap it at the retail shop where you bought it!!
 

·
Registered
Joined
·
59 Posts
Discussion Starter #4
Yup, thanks for the comments. I exchanged it today. The new box had a scrape on the side and looked a little "punched in", but the loading guys didn't think it was anything to be concerned about. When I got it home and opened the box, several of the styrofoam inserts were cracked, and two of them had pieces that had broken off. The TV itself didn't have a scratch on it and it seems to work ok, but jeez. Don't you hate it when you buy something and the box was damaged even though the item appears fine? There's always this sense that what you bought was damaged just enough to break early.
 
1 - 4 of 4 Posts
Top