AVS Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi

Iam having Sony LCD model KLV 26S550A and from the last one week it is showing me blur images on the screen. I have done factory settings but still same. Please provide a solution for this issue.


Thanks
Kumar
 

Attachments

·
Registered
Joined
·
7,233 Posts
Hi

Iam having Sony LCD model KLV 26S550A and from the last one week it is showing me blur images on the screen. I have done factory settings but still same. Please provide a solution for this issue.


Thanks
Kumar
OUCH! That's much more than blurring. This is likely a Sony subcontract rebadge panel and a 550 series even in larger sizes is a budget panels with PQ issues.

You may want to consider removing whatever cables you connecting and reseating them fully or even replace with an alternate cable. A loose or disconnected connector can cause a color distortion like this if your using component and any of the RGB gets disconnected/loose or located with the wrong color but you fail to ID type of connector.

HDMI?
Component?
Composite?

Whatever one - they can replicate such a distortion in PQ.

Age of panel? Warranty Status?

Some of these small LCD's/Monitors have shorter life spans as profit margins have dwindled the past ten years.

I'd work on your connection interface first as I've witnessed this replicated in my home and the network I managed where I had over a thousand 23" LCD's to service/support. Good Luck!
 
1 - 2 of 2 Posts
Top