AVS Forum banner
1 - 4 of 4 Posts

·
Banned
Joined
·
1,338 Posts
Discussion Starter · #1 ·
Got a new pair of paradigm studio 60's and i found that a cap on one of the speaker's posts is removed, exposing the metal jack underneath. Don't know why the cap is off, i just unboxed it, could be due to faulty transportation. The rest of the speaker is okay, the metal jack that got exposed after the cap is off appears safe. The cap itself doesn't appear to be physically damaged, it is just removed from the post. How do i put the cap back on, i tried rotating it clockwise and anti clockwise but it isn't working? And second question, i have built my speaker wire using banana plugs, the banana plug seemingly fits right into the exposed metal jack, but would it be safe to use the banana plug without the cap on?
 

·
Registered
Joined
·
980 Posts
Just stick the banana plug in and forget about it. It just slips past the cap anyway. I have some Infinity Beta 20's that are missing all the caps.


I also have some Studio 20's and ADP's V1 and V2's and the whole speaker seems to be of pretty good quality except maybe the binding posts. They don't screw down as securely as I'd like. It seems as though the threads on the caps are a size too big for the posts.
 

·
Registered
Joined
·
980 Posts

Quote:
Originally Posted by jdcrox  /t/1521616/broken-binding-post#post_24457142


If they are new speakers, I would return them. You will be thinking about that binding post as long as you own them.

I kind of glossed over the "bought a new pair..." part. Oop's. At least notify the seller and see if he will authorize the minor repair or work with the shipper for a partial refund.
 
1 - 4 of 4 Posts
Top