AVS Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi everyone,


I have an Insignia ns-LCD47HD-09...and the screen does not work. the red led works and when I turn the TV on the blue LED comes up and stays on. I have tried the unplug, unplug and hold power button tricks but they don't work. the screen does not light up, stays black. What part might I need to replace? Any suggestions?


Thanks!!
 

· Registered
Joined
·
174 Posts
You'll need to troubleshoot either the main, power supply, or inverter boards.


Good luck,

Jim
 

· Registered
Joined
·
1,138 Posts

Quote:
Originally Posted by vineyards4 /forum/post/20791617


Hi everyone,


I have an Insignia ns-LCD47HD-09...and the screen does not work. the red led works and when I turn the TV on the blue LED comes up and stays on. I have tried the unplug, unplug and hold power button tricks but they don't work. the screen does not light up, stays black. What part might I need to replace? Any suggestions?


Thanks!!

are you still able to change the channels? can you hear the sound?


Boky
 

· Registered
Joined
·
1,138 Posts
Ok then, you should start with power supply board. Connectors should be labelled at their pins with correct voltage values under the load; this means that you should forget about checking those values if you never worked with electronic parts that contain lethal voltages.


Boky
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top