AVS Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
275 Posts
Discussion Starter · #1 ·
Hey folks,


I've got Verizon FIOS for TV service and have the HD box. I have it connected to my Samsung LN40A630 through HDMI. Then I have a fiber optic digital out going from my TV to my receiver (which supports 5.1).


I'm currently watching the new Incredible Hulk on HBO HD which is broadcast with 5.1. I'm only getting sound out of two Fronts and center though. Nothing is coming out of my surrounds. I've tried other channels and same thing.


Any ideas why? I have the TV set to "External Speaker". I have the cable box set to "Surround" (rather than "Stereo"). My receiver shows it's a got a digital connection.


Note...I do get full 5.1 when watching DVDs, but for DVDs, the audio cable is hooked directly to my receiver because my DVD player doesn't have HDMI.


What am I missing here? Why am I not getting sound out of my surrounds?


Thanks for the help!
 

·
Registered
Joined
·
396 Posts
Ran into this same problem with my LN52A630. Samsung's for some stupid reason only pass 5.1 audio out of the fiber connection when using the internal tuners. HDMI input audio automatically gets downrezzed to PCM stereo. Only choice is to run HDMI straight to AV receiver (if you have HDMI switching) and HDMI output to TV. Or run a separate Fiber/Coax from your source to the AV receiver. Pain in the butt I know. I'm waiting a few months and then purchasing an HDMI switching receiver.
 

·
Registered
Joined
·
275 Posts
Discussion Starter · #3 ·

Quote:
Originally Posted by ndoggac /forum/post/16951278


Ran into this same problem with my LN52A630. Samsung's for some stupid reason only pass 5.1 audio out of the fiber connection when using the internal tuners. HDMI input audio automatically gets downrezzed to PCM stereo. Only choice is to run HDMI straight to AV receiver (if you have HDMI switching) and HDMI output to TV. Or run a separate Fiber/Coax from your source to the AV receiver. Pain in the butt I know. I'm waiting a few months and then purchasing an HDMI switching receiver.

Ughhh....really? That sucks big time! Anybody have a solution for this? Maybe a firmware release fixed this?
 

·
Registered
Joined
·
3,637 Posts
The only way is from the Fios box to the Receiver. Their will never be a firmware update. This shouldn't be a big deal as the Receiver and Fios box should be next to each other.
 

·
Registered
Joined
·
275 Posts
Discussion Starter · #5 ·
It's a big deal cause it means I'll have to buy a new receiver as my current one only has 2 digital audio inputs and I've got more sources. My plan was to input the sources to the TV through HDMI and output one audio to my receiver.


Darn Sammy...I love your TV, but you let me down in this case!
 

·
Registered
Joined
·
396 Posts
Unfortunately this is not limited by firmware but by hardware. I forget the exact details, but I looked at a system diagram one time....and it's one of three cases.....


1. HDMI handling chipset does not have a 5.1 audio output to send to a fiber handling chipset 5.1 input


2. Fiber handling chipset has no 5.1 input to accept a 5.1 audio output from the HDMI chipset


3. Both


I didn't know this either before I bought the TV. Had it all hooked up too, assuming 5.1 passing from HDMI to fiber. Had to rewire everything once I realized what the deal was! Eventually will have to rewire again when I get the new HDMI switching receiver.
 

·
Registered
Joined
·
1,244 Posts
The only TV I have seen that does 5.1 via optical out is a Panasonic 32S1 (and a couple other models around that area), haven't really looked much though.

Luckily I only have room for stereo speakers, ha
 
1 - 8 of 8 Posts
Top