AVS Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Objective: Direct audio and video from computer to Denon receiver via optical and HDMI.

Here's my situation: I don't have a discrete graphics card, but I'm currently running two monitors (Either main monitor + TV or main monitor + secondary monitor). I also have an optical cable running to the Denon receiver. I can't seem to get audio out through that cable. However, when I have an HDMI cable running to the receiver, I get audio and video. I'm baffled as to what differently I need to do to get audio through the optical cable. I've tried to switching to the input on the receiver that is set up for optical but I get nothing. Is there some other setting in the computer I'm missing?
 

·
Registered
Joined
·
1,370 Posts
Have you disabled Audio from HDMI, and Enabled it on the Toslink (Optical)? That could be your issue!
 

·
Registered
Joined
·
15,085 Posts
Objective: Direct audio and video from computer to Denon receiver via optical and HDMI.

Here's my situation: I don't have a discrete graphics card, but I'm currently running two monitors (Either main monitor + TV or main monitor + secondary monitor). I also have an optical cable running to the Denon receiver. I can't seem to get audio out through that cable. However, when I have an HDMI cable running to the receiver, I get audio and video. I'm baffled as to what differently I need to do to get audio through the optical cable. I've tried to switching to the input on the receiver that is set up for optical but I get nothing. Is there some other setting in the computer I'm missing?
Assuming you're using Windows, you have to set the default audio output device in the Playback Devices menu (right-mouse-button-click on the Speaker icon at the right end of the taskbar).

Also, you might need to set the default audio output device in the audio configuration menu of whatever Media Player software you're using. This is especially the case if you're using one that supports WASAPI and not just DirectSound.
 

·
Banned
Joined
·
4,945 Posts
Depending on sound chip/drivers might be a dedicated application as wll in which you can set the output options so the digital out, optical, is carrying the signal. I have hdmi, line out and optical. If I want to use the optical I have to tell the audio out options to do so otherwise no sound on optical out.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
In the Playback Devices window, this is what's listed when both HDMI and optical cables are connected:

Denon-AVR
High Definition Audio Device
Default Device

Digital Audio (HDMI)
High Definition Audio Device
Not Plugged In

Speakers
Realtek High Definition Audio
Ready

Realtek Digital Output
Realtek High Definition Audio
Ready


Maybe it's not even detecting the optical cable? I don't understand the Digital Audio (HDMI) option displaying "Not Plugged In" when I have the HDMI cable connected. Also, I am running Windows 8.1. I apologize for not stating that in the original post. I have an Asrock motherboard although I can't remember the model. Another goofy thing is that the 3.5 mm line-out only works when the HDMI isn't connected. I take it that's because it's defaulting to that input when connected? Even when I have a second computer monitor (instead of the TV through the AVR) connected via HDMI it does this. Aside from fiddling with the settings, would I need to download/update any drivers? I'm just curious since it's a custom built PC. Thanks
 

·
Registered
Joined
·
15,085 Posts
In the Playback Devices window, this is what's listed when both HDMI and optical cables are connected:

Denon-AVR
High Definition Audio Device
Default Device

Digital Audio (HDMI)
High Definition Audio Device
Not Plugged In

Speakers
Realtek High Definition Audio
Ready

Realtek Digital Output
Realtek High Definition Audio
Ready


Maybe it's not even detecting the optical cable? I don't understand the Digital Audio (HDMI) option displaying "Not Plugged In" when I have the HDMI cable connected. Also, I am running Windows 8.1. I apologize for not stating that in the original post. I have an Asrock motherboard although I can't remember the model. Another goofy thing is that the 3.5 mm line-out only works when the HDMI isn't connected. I take it that's because it's defaulting to that input when connected? Even when I have a second computer monitor (instead of the TV through the AVR) connected via HDMI it does this. Aside from fiddling with the settings, would I need to download/update any drivers? I'm just curious since it's a custom built PC. Thanks
I don't understand the HDMI audio entry either. It might be left over from when no display was connected to the receiver, but that's just a guess. Usually when an HDMI device is not connected, it isn't even visible in the audio configuration menu. To find out exactly what the system is seeing you might want to consider downloading Entech's MonInfo utility. It shows the details of the EDID information provided by the currently active HDMI device. By itself, Windows just shows cached information, which might be obsolete.

I suspect the optical out is the "Realtek Digital Output". Try selecting it and then clicking on the Configure button. That should show you the audio formats that it supports. Two channels of PCM should be available for the optical output, along with 5.1 channels of Dolby Digital and DTS.

Do that for the HDMI devices, too. Configure the active one for all 5.1 (or 7.1) channels. (Let the receiver do any necessary down-mixing if you have fewer speakers.)

It's usually a good idea to install the latest graphics and audio drivers from the sites of the manufacturers of the chipsets, but first check the Web site of the manufacturer of your motherboard. Sometimes they do something to interconnect the chipsets so that only their drivers work.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Okay, I got it working now. It really is as simple as disabling the playback device Windows defaults to whenever there is a connection and/or disconnection. I feel kind of silly now. I didn't realize I would have to manually do this every time. I guess I just wasn't familiar with the way Windows defaults to an output. I wonder if there's a more convenient method rather than going into sound options. Anyway, I really appreciate the help Selden Ball, jsmiddleton4 and toddman36!
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top