AVS Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
Running HT Omega Claro > SPDIF > Marantz 9200 > Speakers.


About 6 months ago when I bought the speakers and receiver, I bought an M Audio Revolution sound card, but I couldn't get it working 100% how I wanted it to (Wouldn't pass through 100%, I spent *a lot* of time trying to get it working correctly). So I bought a HT Omega Claro. Plugged it in, deleted the old drivers (as best I could, M Audio doesn't make this easy) downloaded the new drivers. Bam! Worked right away. Passed through everything from the SPDIF to the Marantz for decoding... played everything at its native bitrate, it let my AVR decode DD, DTS, etc.


So I had to format the HTPC a couple days ago and reinstall everything. No big deal I assumed, it was pretty much plug in play last time, which after all the fooling around with the M Audio was quite the relief. I guess I couldn't be more wrong. The HT Omega Claro wont pass through anymore. It only plays the bitrate I which is selected as the "Default Format" in W7. This is under Sound > Properties > Advanced. if I select 24/92, my receiver is getting 24/92, if I select 16/44.1, that's what it gets, etc. And it wont pass through any DD or DTS for movies.


I have the on board sound disabled in the bios and I am running 'SPDIF Pass through', not 'Speakers' in the W7 setup. I have tried both ways.



This is super frustrating. Any help would be appreciated. I searched, but to no avail.





Edit: When I formatted, I did not remove the sound card or the video card (Nvidia GT430).
 

·
Registered
Joined
·
53 Posts
Discussion Starter #3

Quote:
Originally Posted by Mrkazador  /t/1524311/cant-get-my-soundcard-to-pass-through-to-my-avr-help-appreciated/0_50#post_24529876


Did you enable bitstream in your audio decoder?

Sorry, I'm not sure I understand. I think you mean my AVR (as it should be the one decoding), in which case I dont have to choose anything. I can put it on an 'Auto' setting and it sees what is being input and adjusts accordingly.


From what I can tell, W7 is definitely getting in the way. I have googled and run through everything I can remember and dont see what else I can change.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #5

Quote:
Originally Posted by Mrkazador  /t/1524311/cant-get-my-soundcard-to-pass-through-to-my-avr-help-appreciated/0_50#post_24529925


The audio decoder in the media player you are using should have an option to enable bit streaming/spdif.

I am testing on VLC and Foobar2000 and I have never had to do that on either. FWIW, I did notce this beforehand and just for the hell of it I tried it and it didnt change anything. I also just deleted the GT430 audio drivers to try that, but it didnt do anything either.



Why I am convinced windows is in the way is: In the w7 sound options (note: not the sound cards software) You can 'test' to see what formats are supported. DD, DTS, 44.1k, 44k, 96k all make sound from my speakers when tested, and they initiate my AVR to 'change'. The DD, DTS, or 96k label on my AVR flashes, depending on what I am testing. But when I go to play media, it reverts back to whatever the "Default Format" is set to in Sound > Properties > Advanced.
 

·
Registered
Joined
·
4,371 Posts
Vlc should have an option to output spdif. You also need to set your sound cards spdif output as the default audio device in the sound control panel. If you don't do these two thing, bitstreaming won't work.


As for foobar2000, download the wasapi plugin and use that as the audio renderer. This will bypass the windows audio mixer and pass though the audio as-is.
 

·
Registered
Joined
·
1,035 Posts

Quote:
Originally Posted by ridindirty  /t/1524311/cant-get-my-soundcard-to-pass-through-to-my-avr-help-appreciated#post_24529955


I am testing on VLC and Foobar2000 and I have never had to do that on either. FWIW, I did notce this beforehand and just for the hell of it I tried it and it didnt change anything. I also just deleted the GT430 audio drivers to try that, but it didnt do anything either.



Why I am convinced windows is in the way is: In the w7 sound options (note: not the sound cards software) You can 'test' to see what formats are supported. DD, DTS, 44.1k, 44k, 96k all make sound from my speakers when tested, and they initiate my AVR to 'change'. The DD, DTS, or 96k label on my AVR flashes, depending on what I am testing. But when I go to play media, it reverts back to whatever the "Default Format" is set to in Sound > Properties > Advanced.

In that same advanced menu, do you have the two exclusive mode options checked?
 

·
Registered
Joined
·
53 Posts
Discussion Starter #8

Quote:
Originally Posted by Mrkazador  /t/1524311/cant-get-my-soundcard-to-pass-through-to-my-avr-help-appreciated/0_50#post_24529979


Vlc should have an option to output spdif. You also need to set your sound cards spdif output as the default audio device in the sound control panel. If you don't do these two thing, bitstreaming won't work.


As for foobar2000, download the wasapi plugin and use that as the audio renderer. This will bypass the windows audio mixer and pass though the audio as-is.

I tried that VLC option. It made no difference. The sound card is setup to output via SPDIF. I understand where you are coming from, but I didn't think I needed to setup foobar with wasapi for my AVR to output the correct format.


Again, this works correctly when 'testing' via the windows sound setup. Anything is possible, but does it seem to you like the sound card or the AVR is getting in the way? Seems to me like Directsound is interfering. Its also possible I was outputting full time wasapi some other way before I formatted and dont remember how I set it up. Although I had XBMC and JRiver on the HTPC before the format, both VLC and Foobar let the AVR process the sound.

Quote:
Originally Posted by Andy_Steb  /t/1524311/cant-get-my-soundcard-to-pass-through-to-my-avr-help-appreciated/0_50#post_24530123


In that same advanced menu, do you have the two exclusive mode options checked?

I tried having them both checked and unchecked.


I also tried choosing my sound card as a 'speaker' in the windows options, rather than as SPDIF Pass-through and it didnt help either.
 

·
Registered
Joined
·
4,371 Posts
You don't need wasapi but its nice to have because it can change the sample rate to that of the source audio so you don't have to change it.


In the sound card drivers, is there an option to enable the spdif output? Have you tried a different media player like mpc hc?
 

·
Registered
Joined
·
53 Posts
Discussion Starter #10
The software for my soundcard knows I am using SPDIF. I dont need to select it per se.


I'll download XBMC and the WASAPI plug in for Foobar2000 and report back.
 
1 - 10 of 10 Posts
Top