AVS Forum banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
757 Posts
Discussion Starter · #1 ·
hello all.

i sat down this evening to enjoy a rental when i noticed that my center channel just didn't sound right. the dialogue was muffled and did not have a lot of range. the sound effects coming from the other speakers blew the center out of the water. i double checked all of my settings to make sure everything was setup correctly. yes, it was still detecting a DD setup and the speaker levels were not out of whack. hmm...

so i switched a mini monitor w/ the cc370 and the mini monitor was not muffled. the most noticeable difference was when i ran white noise through the speakers w/ the receiver's speaker lvl setup screen. what's wrong here? damaged crossover on the cc370?
 

·
Registered
Joined
·
97 Posts
I would say perhaps...that or the tweeter.


I had the same thing happen with my CC350. It would sound okay at lower volumes (maybe I wasn't paying attention at these times), however at reasonably normal/louder volumes it sounded compressed and had no dynamic range.

I took it into a local dealer, they unscrewed the tweeter and it was "cooked". They replaced it (tweeter) within a minute and all has been fine since. The dome tweeter was bronzed/brown around the outside. They indicated that it may be due to my receiver clipping as a result of being pushed too hard.


Bottom line, take it into a dealer if possible and have them take a look at the center channel.


Matt
 

·
Registered
Joined
·
757 Posts
Discussion Starter · #8 ·
couple years old. i'm not listening at extremely large volume levels. hmm?


well, does anyone know where i can get a tweeter replacement???

my nearest paradigm dealer is very very far away. any help here????


i guess my other option would be to upgrade the center (as some have done) to the studio line.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top