AVS Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Hey guys, I couldn't find a clear answer on what cable to use to connect the denon receiver to the mlt2 subwoofer. The receiver has a single out and the subwoofer and a red LFE-In (Right in) and a white Left In.


Do I use a standard Dynes Subwoofer cable to connect the receiver out to the LFE In, or do I use a Dynes RCA stereo Y cable to connect the receiver out to the red in and white in.


I also found a cable on amazon by KabelDirekt Pro Series Subwoofer Cable Y RCA cable / Digital Cable, RCA male to 2 x RCA male. That appears to be the same as the other Dynes red/white cable, only much better and more shielded.


Not sure how to proceed....as always thanks for the input and I'll throw the same post on the receiver forum.


Thanks
 

·
Registered
Joined
·
5,049 Posts
Just go with one rca. I had that subwoofer and loved it!
 

·
Banned
Joined
·
15,491 Posts

Quote:
Originally Posted by theaterjunkie12  /t/1520507/connecting-denon-e400-to-mlt-2-subwoofer#post_24428370


Ok, does it get plugged into the red (lfe in) or white (left in)
I know that in so doing you run the the risk of having your Man Card revoked, but have you tried looking at the owners manual?
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #8 ·
Guess I'm confused on what "low level input" is and why they would put 2 inputs. But everything works great with the one cable!


I mounted the speakers with the dynex wall mounts from best buy and appear to be ok-I don't see a weight problem. And following the "don't over tighten" is necessary. I was going to try the videosecu mounts as they hold more weight, but I believe they will stand out farther from the wall.
 
1 - 9 of 9 Posts
Top