AVS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hi - I am trying to control MediaPortal with the remote included with my Hauppauge 2250 tv tuner card (model #1213). It says it is a MCE compatible remote (and it looks like and MCE remote), however, I don't have MCE, I'm just running XP Pro. The ir receiver plugs directly into the hauppauge card (not the usb). I have toggled the MediaPortal remote configuration options to both Hauppauge and MCE and neither work. However, I do know my remote is working as it will control the Hauppauge's WinTV application. Also, interestingly enough, when I use the learn feature in MediaPortal and I press any button on my remote, it changes the x10 key to 0. So I assume that the remote is communicating with MediaPortal, but MediaPortal can't make any sense of it.


Anyone else have this configuration working? Any advise on what I can do?


Much appreciated,

Eric
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
OK. Doesn't seem like many others are having this problem, but I'll post my resolution anyway just in case it can help someone else.


After much trial and error, I got my remote to work by actually not using any remote option in mediaportal. I believe mediaportal is confused by the fact that it is an mce remote being used through the ir reciever that plugs into the hauppauge card (as opposed to the USB ir receiver). It sounds like media portal can either use the [mce remote with the usb receiver] or [the hauppauge remote with the ir receiver that plugs into the hauppauge card], but not [the mce remote with ir receiver that plugs into the hauppague card]. Actually, I should also specify that I'm not running MCE, just Windows XP SP3. That might contribute to the remote communication problem too, but I suppose I wouldn't need mediaportal if I had MCE.


I had to program the c:\\windows\\irremote.ini file. This file is used by hauppauge to translate ir signals to windows inputs (like keyboard strokes). I mapped the remote ir signals to the keyboard shortcuts used in mediaportal. I am not a programmer by any means, and I figured it out. I just searched for "irremote.ini documentation" in google and I found some decent guides/tutorials.


Just to be clear, this is my hauppauge 2250 MCE kit contents (note, no usb ir):

 

·
Registered
Joined
·
3 Posts

Quote:
Originally Posted by emkepler /forum/post/16962739


OK. Doesn't seem like many others are having this problem, but I'll post my resolution anyway just in case it can help someone else.


After much trial and error, I got my remote to work by actually not using any remote option in mediaportal. I believe mediaportal is confused by the fact that it is an mce remote being used through the ir reciever that plugs into the hauppauge card (as opposed to the USB ir receiver). It sounds like media portal can either use the [mce remote with the usb receiver] or [the hauppauge remote with the ir receiver that plugs into the hauppauge card], but not [the mce remote with ir receiver that plugs into the hauppague card]. Actually, I should also specify that I'm not running MCE, just Windows XP SP3. That might contribute to the remote communication problem too, but I suppose I wouldn't need mediaportal if I had MCE.


I had to program the c:\\windows\\irremote.ini file. This file is used by hauppauge to translate ir signals to windows inputs (like keyboard strokes). I mapped the remote ir signals to the keyboard shortcuts used in mediaportal. I am not a programmer by any means, and I figured it out. I just searched for "irremote.ini documentation" in google and I found some decent guides/tutorials.


Just to be clear, this is my hauppauge 2250 MCE kit contents (note, no usb ir):


I have the same issue. I am running Media portal 1.0.2 on a window xp pro machine..(NO MCE)

Was able to manage to map power button of the Happaugue HVR-2250 remote.

Vol up & Down works....no other buttons on remote seem to work.


Can you attach irremote.ini file please.

Thanks!
 
1 - 5 of 5 Posts
Top