AVS Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Sorry if this is in the wrong place. It's my first time posting. Anyways , I recently bought a KDL-46XBR ........ it played beautifully for 3 weeks until I tried to mount it on the wall. As soon as I turned it on , there was a stress crack in the LCD that would get bigger if you depressed the screen. Now it's about 12 inches across and has rainbow lines running through it all up and down the TV. I know the LCD is ruined but I'm wondering if anyone else has come across this problem. We installed and mounted very carefully so I know it wasn't in the install. What I do believe is that there was a tiny stress crack from the factory that happened to run when we put stress on the chassis. Anyone have any similar experience or opinion about my theory. Thanx
 

·
Registered
Joined
·
170 Posts
yeah bring it back, say it was like that when you plugged it in.


Unless of course you tried to cut corners and bought the tv from a less expensive store with some non 30 day return policy. Then your screwed im afraid
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
Bought it from a reputable dealer in New York and I'm in California. Return was not an option from the get go because of size. Been in touch with Sony and they're being hard nosed about it saying it was external damage............. this is even after Sony authorized dealer inspected and agreed that nothing is externally wrong with it. Time to get hard nosed myself and fight the system I guess. Thanks for the insights. Still interested in hearing from some one with similar situation and how it turned out for them.
 

·
Registered
Joined
·
1,329 Posts

Quote:
Originally Posted by Dicey1 /forum/post/0


Sorry if this is in the wrong place. It's my first time posting. Anyways , I recently bought a KDL-46XBR ........ it played beautifully for 3 weeks until I tried to mount it on the wall. As soon as I turned it on , there was a stress crack in the LCD that would get bigger if you depressed the screen. Now it's about 12 inches across and has rainbow lines running through it all up and down the TV. I know the LCD is ruined but I'm wondering if anyone else has come across this problem. We installed and mounted very carefully so I know it wasn't in the install. What I do believe is that there was a tiny stress crack from the factory that happened to run when we put stress on the chassis. Anyone have any similar experience or opinion about my theory. Thanx

How did you pay for it? If you used an Amex card (or equivalent), you may have accidental breakage coverage.


ft
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top