AVS Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
389 Posts
Discussion Starter · #1 ·
I just bought the 1200 a few days ago. Mine will play all movies but Crank. It will work fine until the main menu but at that point it won't give you any thing to choose from, it just has a background. So I decided I would take my copy back to BB to see if it would work on one of their players (a bdp 1200) and it wouldn't. So I tried 2 more and the same thing happed. I then tried it on the Sammy BD-P1000 and it worked fine!


Since these Crank BR movies would play on the Sammy 1000 but not the 1200 do you think there are some bad Crank BR disks or do you all think it might be the players?
 

·
Registered
Joined
·
1,292 Posts
geez...


all movies but crank play; obviously you have a bad player. it's the only logical conslusion.
 

·
Registered
Joined
·
389 Posts
Discussion Starter · #3 ·

Quote:
Originally Posted by youknowryan /forum/post/0


geez...


all movies but crank play; obviously you have a bad player. it's the only logical conslusion.

Try and read the whole post. You know you might have A.D.D. (just a thought)


I said I tried it on 2 different players with 3 different BRDs with the same results.
 

·
Registered
Joined
·
2,155 Posts
Anyone else with the 1200 have crank to try? please post.
 

·
Registered
Joined
·
389 Posts
Discussion Starter · #6 ·
Good to hear. I am going to rent one from netflix and see if that works. someone else in the BR hardware forum said Crank wouldn't play on his either. Maybe there are some discs going around that don't like the 1200.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top