AVS Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Hello guys i have a crazy problem and im trying to fix it


Onkyo TX-906
Problem: Burning fuses, Smoking Resistors - Resistances - no sound - why no sound? because after this problem happens a RELAY sound before 1 CLICK RELAY SOUND when pressing the power bottom SECOND RELAY SOUND, speakers working

The power supply are OK, anyone can help me TO FIX where i need to look,inspect check etc? or replace?
 

·
Registered
Joined
·
7,063 Posts
Hello guys i have a crazy problem and im trying to fix it


Onkyo TX-906
Problem: Burning fuses, Smoking Resistors - Resistances - no sound - why no sound? because after this problem happens a RELAY sound before 1 CLICK RELAY SOUND when pressing the power bottom SECOND RELAY SOUND, speakers working

The power supply are OK, anyone can help me TO FIX where i need to look,inspect check etc? or replace?

What you need is a qualified experienced audio electronics technician to diagnose and repair the unit.

If you don't have someone local who is qualified, send it to Onkyo for repair.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
THnks

What you need is a qualified experienced audio electronics technician to diagnose and repair the unit.

If you don't have someone local who is qualified, send it to Onkyo for repair.
Thanks but i prefer doing my own repair what i need is advice help its old onkyo model i check this morning and i think i have a problem with the power protection or/and short somewhere or/and a defective part or parts
 

·
Registered
Joined
·
617 Posts
You are very brave.
 
1 - 7 of 7 Posts
Top