AVS Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
I just upgraded my digital cable (Philadelphia area) to HDTV and received the Motorola DCH-3200 self install kit by mail. I called the number to activate it, waited my 45 minutes; nothing.


I called 1.800.COMCAST and had them send a new signal. Now the TV displays local channels (ABC, NBC, CBS, Fox, etc) and their HD equivalents, but not any of the other channels I pay for (TNT, Discovery, HBO, etc). These channels all display "One moment please, this channel will be available shortly."


I was told by a Comcast CSR to wait 3 days (72 hrs) to have these channels show up or have a tech come out. Does it really take this long? Comcast reps have been wrong about just about everything else I asked and claim everything looks fine on their end. The connection is bare bones. Cable into box, HDMI to TV.


Thanks for any help.
 

·
Registered
Joined
·
22,837 Posts
You may have a "filter" installed blocking the additional channels (just a guess). If they have to dispatch and make you wait, call back and speak with a supervisor. They should resolve your "self install" issue ASAP or they shouldn't charge you until it's working properly.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #3 ·
I'll try calling back. It's so aggravating talking to them or trying to get a supervisor.


Also, I tried hooking up my old cable box (the one I was trading in) and all channels came through fine (if that makes a difference).
 

·
Registered
Joined
·
22,837 Posts
On the old box... Digital channels are good?


If so... then I'd call and really raise hell. Activation of a new box should take two minutes.


With a promotion for self-install, YOU should not be inconvenienced and have to wait for anything. Squeaking wheel gets the oil. Ask for some type of "compensation".
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #5 ·
Yes all digital channels, premium and otherwise, appear on the old box just as they did before I got the new one.


The last rep told me all she could do is send a signal (or of course have me unplug it). This always does nothing. And they claim all is well on their end...
 

·
Registered
Joined
·
16,749 Posts
Sound like they either have the wrong box serial number or other information for you new box in their files or they have not entered it all correctly or that you have a defective box.
 

·
Registered
Joined
·
22,837 Posts
Freakin' idiots. Apparently they "activated" the new box, but not properly to allow all of the channels to which you subscribe. It shouldn't take three days.


Just for kicks.... ask if they can copy the "profile" of your old box and add to the new box.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #9 ·
Arxaw's solution is looking more and more viable as I have never been able to accomplish anything with Comcast without a fight. (I ordered the box on Dec 8 and received it on Jan 2).


I provided the Mcard serial on the box/enclosed letter to several of their associates to no avail. Maybe I will try the activation line again.


I suppose it's possible a brand new box could be defective. I don't know enough about them to know their reliability.
 

·
Registered
Joined
·
22,837 Posts
Don't give up the fight. Get your freebies for the aggrevation.

Could be a a "bad box", but doubtful IMO. If you get digital channels, it's working. If you don't get 'em all, that's incompetancy on their part.


$5 says they aren't trained properly to support/activate the new cable boxes or MCard.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #11 ·
For those interested, I contacted the activation line once again and spoke with a moderately helpful rep ("moderately" being at the top of Comcast's scale. He sent a refresh signal (the signal that should have been sent initially) and now all is well. All channels and on demand work fine. So much for waiting 3 days or having a tech sent out. A little training would go a long way.


Thanks for all the input.
 

·
Registered
Joined
·
22,837 Posts
Glad it's resolved...

Next bill they send, tell them you paid it and it should show up in 72 hours or they can send a tech to pick it up.
 
1 - 12 of 12 Posts
Top