AVS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a Denon AVR-1912 that has worked great for the last 5-6 months. Today I went to turn on my system and the receiver is no longer sending the signal to the TV or able to pick up signals from the devices that are connected to it. The DVD player, Apple TV, TV, and satellite are all connected to the receiver via HDMI cables. The only thing that the receiver will do is play the radio on tuner mode. Its like all of the HDMI inputs AND outputs no longer work. I tried switching HDMI cables from other areas in my home with no luck. I also made sure it was not the TV by hooking up the DVD player directly to the TV via HDMI and it worked fine. I shut down everything, unplugged everything let it sit for 20 minutes and tried to hook it back up and the problem is still there. I have no clue what to do at this point...

Thank you!!!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I did try the microprocessor reset as wel, I forgot to that in the initial post. We did have a storm but all of the components go to a serge protector and the receiver is the only thing in the house that would have been effected. Thank you.
 

·
Registered
Joined
·
5 Posts
I have learned that the HDMI boards are the weak link in the otherwise terrific receivers. I purchased a refurbished model with the insurance plan. Like you, I tried everything to get it going with No luck. I talked to a Denon repair center from their website and he said those boards can get shorted out very easily. The insurance company is sending me a replacement value check without even requesting the receiver back. It seems that they knew that there was no grounds to argue the point


If you find a place to repair it, let me know. [email protected]
 
1 - 5 of 5 Posts
Top