AVS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter · #1 ·
I just tried running my Xbox with the HDMI cable to the projector, and to my dismay...the screen is full of pixels flashing and flickers...now if I use HDMI 1 it will select 1080p but with the above, if I use HDMI 2...it will only select 1080 DVI and slightly less visible flickers but still there....

The cable is 50 ft due to the fact I couldn't pass it in the ceiling...now the Bell receiver has no issues...
 

·
RETIRED theater builder
Joined
·
36,565 Posts
Step one is to verify that the HDMI cable is the problem by moving the xbox closer and using a shorter HDMI cable.


Assuming it works then you are going to need to use an extender or other strategy.


Just a FYI when I was using a 10M DVI cable I had some problems with just one item in my rack, an early Oppo player. Passing it through a Gefin switch which "boosted" the signal to full standard voltage solved the problem. At the time my reading on the subject indicated that some devices just put out a slightly weaker signal and with the distance it just didn't make it intact.
 

·
Registered
Joined
·
84 Posts
Discussion Starter · #3 ·
I did indeed try it with a shorter cable and the issue was resolved...so extender it is?

Now are there HDMI switches that have a booster or extender?

I know it is suggested to have the extender at the display so I take it no?
 

·
Registered
Joined
·
423 Posts
Did you try the Bell receiver with the long cable? Sounds like might simply be a faulty cable.
 

·
Registered
Joined
·
84 Posts
Discussion Starter · #5 ·
The receiver is fine, no issues shows 1080i (highest for Bell at the moment) without any screen flicker
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top