AVS Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
I'm having a bit of a problem playing back HD DVD's on my HTPC. I don't think the problem is hardware related, but I've been unable to resolve it. I did some searching here and elsewhere and couldn't seem to find a solution. I thought someone else here might know of a solution.


Basically, power dvd seems to be dropping frames occasionally. It's most noticeable with fast movement or when the camera pans. I know it's not in the recording, as a buddy has played the same movie on his system. He noticed the problem on mine before I said anything, but he didn't notice it on his.


Anyway, the system is a hoss, and CPU usage doesn't go over 40% so I don't think that's the problem. Specs are:


Intel E4300 @ 3GHz

Asus P5W64 WS Pro (Intel 975 based)

2GB OCZ DDR2-800

MSI Geforce 7300GS w/ HDMI (550MHz GPU/800 MHz RAM)

M-Audio revolution 5.1

Western Digital 2500JD (for programs and OS)

WinXP MCE

PowerDVD 7.2 Ultra


I was originally trying to play the movies off of my media server over the gigabit network. I thought that might be the problem, so I copied the movie to the hard drive and that didn't fix the problem. I'm currently using Nvidia's 94.24 drivers.


The only thing I can think of that might be the problem is the video card. My buddy has an 8800GTX in his system. However, with a core clock of 550MHz, I think this card should be able to handle it. Task manager isn't indicated that I am maxing out the CPU by any means, either (40% CPU usage max during playback).


Any tips are appreciated. So far, PowerDVD is the only program I can get to playback HD-DVDs at all. If there are any others that work better, let me know.


Thanks,

Tristan
 

·
Registered
Joined
·
2,914 Posts
I had a 7300GS with a e4300 at around the same overclock, and it did the same thing. Might possibly be fixed if you update to the latest 7.3 (the slipstream install, _not_ the website patch), and maybe more modern drivers? (not sure, don't use XP anymore).


Might be a memory bandwidth issue, perhaps Turbocache related? Have you tried with hardware acceleration off? (you've got miles more CPU power than needed even in software mode). Oh, and perhaps motherboard chipset drivers?
 

·
Registered
Joined
·
230 Posts
I had been trying to figure this out for a few months and I fixed it by disabling the clear type text checkbox in PowerDVD.

When you turn this on PowerDVD enables the graphics card to do HW deinterlacing of HD content. This will choke your graphics card and cause the stuttering playback. No need to turn this on...
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #5 ·
Thanks for the tips, guys. I didn't have a chance to mess with it at all today, but I'll have a look tomorrow.


I have Reclock installed on the computer, but disabled it as I couldn't figure out how to get DD over SPDIF working with it. It's enabled in the program, as far as I can tell, but all I get is stereo sound... I must admit, I didn't try to hard at it. I just disabled it and went back to the PowerDVD audio filter.


I'm currently using the latest non-beta drivers available from Nvidia. They have later ones for vista, but I don't think they work in XP. I didn't bother trying.


I'm going to check what memory speed my RAM is running at. I never assigned it in the bios, so it might be running at some lower speed than necessary.


I'll also check if hardware acceleration and the clear type thing is enabled in PowerDVD.


I'll update with my results.
 

·
Registered
Joined
·
1,348 Posts
Those are not dropped frames. They are refresh stuttering problems. Try changing the refresh to 47.92hz or as close to 48hz as you can. It should be silky smooth then.


But remember to change it back to 60hz when viewing video based 1080i stuff or you may see the stuttering.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #8 ·
Okay... I had a chance to play with PowerDVD again tonight.


First thing I did was upgrade to the latest version of PDVD, 2911. (just released a few days ago) This didn't seem to fix the problem for me.


So, I tried disabling hardware acceleration. This seemed to improve things a bit, but there was still noticeable stuttering when panning...


So, I tried lowering the refresh rate, as MickeyDora suggested. This seemed to improve things a bit more, but it's really quite a pain. I think if I installed powerstrip, I could make it change the refresh rate whenever I run powerdvd (since I use zoomplayer to play normal DVDs). However, I'm not sure. I haven't used powerstrip in ages. In any case, this didn't completely fix the problem.


So I went back to reclock. I reset all settings to default and had some trouble getting it to run with powerDVD. I didn't have this problem with previous versions of powerDVD. However, if I tell reclock to run with powerDVD and run in place of any directsound/waveout renderers, it runs with powerDVD. I have two reclock icons, but I set them to 30fps and it works. And video is smooth. I compared the same scene to the DVD version, and the DVD seemed slightly smoother. However, the picture was also blurrier. I think this might be due to the interlaced nature of the DVD. As I understand it, BR/HD-DVD is always 24fps progressive. I'm willing to accept this result for the time being. It's a vast improvement on what I was looking at Friday night.


So, if anyone else has this problem, you might give reclock a try.
 

·
Registered
Joined
·
240 Posts
Where'd you download the 2911 release?


I have played 15-20 HD DVDs and have had almost no problems... however, the last week or so I have noticed some of the same issues you describe. A few lost frames, and stuttering in some fast panning/high action scenes.


I installed reclock, but wasnt exactly sure where to go with it specifically. Can you walk me through what I need to do?
 

·
Registered
Joined
·
20 Posts
I would try 93.71 drivers, defragment the hard drive (check connections if defragmentation is too slow), clean registry, close all programs except PowerDVD and turn off hardware acceleration. Turn off smart deinterlacing in PowerDVD.

Also, further overclock to 3.2GHz may help. I had some stuttering with my E6400 untill overclocked to 3.2GHz.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #11 ·

Quote:
Originally Posted by sivart321 /forum/post/0


Where'd you download the 2911 release?


I have played 15-20 HD DVDs and have had almost no problems... however, the last week or so I have noticed some of the same issues you describe. A few lost frames, and stuttering in some fast panning/high action scenes.


I installed reclock, but wasnt exactly sure where to go with it specifically. Can you walk me through what I need to do?

Cyberlink don't seem to have a patch for the 2911 release. However, you can download the full version of this release if you download the latest version of the program. What I did was uninstall the old version, and install the new one...


After you install reclock go to start->programs->reclock->configure reclock.


You will have to check the two options "Force reclock to be loaded in place of default DirectSound/Wave renderers" and "Force reclock to be loaded in powerDVD." This is the bug that I described above. In older versions of PowerDVD, only the second option was necessary. I changed the resampling quality to excellent. I don't believe I made any other changes in there.


Now when you run PowerDVD, you should have two reclock icons in your systray. This is a bug, but it should still work fine. Double click on each one and set the video stream framerate to a factor of your refresh rate. If your refresh rate is 60Hz, then you'd want 30fps. If it's 50Hz, you'd want 25fps.


I'm interested to know if this fixes the problem for you.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top