AVS Forum banner

Status
Not open for further replies.
1 - 16 of 16 Posts

·
Registered
Joined
·
209 Posts
Discussion Starter #1
Ok, I am trying to figure out Dscaler.


I have P4 1.5gig with 512 meg of RAM; which I would qualify as a pretty fast machine. I use Dscaler 3.09, an ATI TV Wonder capture card, and a Radeon 7200 64 Meg of RAM SDR. Rez is 1024x768 at 75hz true-color 32.


When I use an analog source (Satellite or Laserdisc) I get motion artifacts. The picture will jerk once in a while as if it is skipping.


I use Adaptive deinterlacing, no filters, no judder correction, and pull-down auto-detect; that's it.


I tried enabling different filters; that made it worse. I tried the different methods - greedy 2 frames, bob, weave, etc. with very similar results. I also give the program and decoding functions the highest priority.


What do I need to enable/disable to eliminate the motion problem? I am obviuously doing something wrong, I just don't know exactly what.


Thanks!


Sylvain Dumas
 

·
Registered
Joined
·
1,681 Posts
How many frames are you dropping?


Have you tried GreedyHM?


-Steve
 

·
Registered
Joined
·
174 Posts
This may or may not be the same thing, but I've also noticed juddery movement with Dscaler 3.0.9 using GreedyHM or adaptive deinterlacing without filters (haven't tried other deinterlacing methods). Stutters occur every few seconds. This is on an Athlon 1GHz w/ 256MB RAM running at 60Hz refresh (59.97 in Powerstrip). The capture card is one of KBK's Zoltrix mods.


I show zero dropped frames, so that doesn't appear to be it. If I downgrade to 2.3 I get smooth, judder free video with all deinterlacing methods. Strange.


---
 

·
Registered
Joined
·
1,681 Posts
hmm...


GreedyHM is a somewhat picky beast. There are many things that will turn on its E-Cat function. Make sure that the standard auto-pulldown stuff is all turned off (i.e. The only thing that is checked in the deinterlacing section is GreedyHM).


Try dropping the pixel width to as low as possible. Does this make a difference?


-Steve
 

·
Registered
Joined
·
2,379 Posts
acannon: I e-mailed the list about your problem. I think I'm experiencing it too (59.95 Hz), but would like to hear from anybody who isn't experiencing the problem with the latest test releases.
 

·
Registered
Joined
·
174 Posts
Steve,


The stuttering occurs with the other video deinterlacing modes too, not just GreedyHM. I dropped pixel width down with no change. It's most noticeable with sports, particularly hockey. It's hard to tell if it happens at a fixed frequency or not (maybe every 5-10 seconds), but it is really easy to tell with fast pans.


I just did a fresh install of 3.0.9 and checked with the default setup: stutters. Fresh install of 2.3: no stutters.


---
 

·
Registered
Joined
·
2,379 Posts
acannon: if you have moment, could you try a couple of intervening releases, to vector into more closely where the change was done? I did the same routine this afternoon and seemed to have the same problem on 3.0.6, but would like confirmation. Thanks.
 

·
Registered
Joined
·
174 Posts
Dan,


I downloaded the 3.0.x series and went back through the revisions. I tested each for a few minutes using adaptive on a hockey game (adaptive - 2-frame). The problem is definitely there on 3.0.6. I think that the change occurs between 3.0.3 and 3.0.4. This was pretty brief testing, but 3.0.3 seemed okay whereas 3.0.4 stuttered.


---
 

·
Registered
Joined
·
9,884 Posts
There were a couple releases around 3.03 or so that had incompatible drivers. You would have to at least reboot to change versions. But I'm not sure what the effects of this would be in your testing.


BTW, you don't also happen to notice a heartbeat interrupt effect while watching DVD's do you? Or any other video with smooth pan's or scrolling credits or tickers, not using DScaler?


- Tom
 

·
Registered
Joined
·
174 Posts
Tom,


No, I haven't noticed a heatbeat interrupt effect on DVDs or video sources outside of the most recent DScaler betas. Scrolling credits and smooth pans in WinDVD and PowerDVD are fine. Stock tickers in WinDVR are also okay.


---
 

·
Registered
Joined
·
60 Posts
I just started using dScaler (3.0.8) a few days ago, and I'm seeing the same thing: no dropped frames, but periodic juddering. I think I've tracked it down to the pulldown detection going on and off. I have a fairly crappy analog cable signal coming in to my system, and the 3:2 pulldown detection code is constantly changing its mind about which way to go. It's the transitions from 3:2 mode back to adaptive that seem to cause the judder on my system.


Aaron
 

·
Registered
Joined
·
129 Posts
I wish my observations help...


Some channels (Cable NTSC in Taiwan), mostly news report, will have running messages on the side and this is where I compare the video performance in DScaler. I found the vga driver the key. For example, even the latest nVidia driver 21.81 on the Asus V7100 (GeForce2 MX) had running messgase juddered every 2-3 seconds in Win2k, also some beta drivers for my ohter Radeon LE card had it. The official two drivers I've applied from ATI for my Radeon, one from the bundled CD-ROM and one from latest ATI download (3276) have smooth running messages.


Asus P3BF w. Piii 733

256MB DRAM

Upmost UPT 201 tuner card (bt878a)

Radeon LE 32 DDR


Dscaler 3.07 beta, 3.09 beta on Win2k sp2 + DirectX 8.0a + Microsoft Video Capture Update


Good Luck. :)


dpeng
 

·
Registered
Joined
·
1,687 Posts
acannon


Thanks for helping to pinpoint the problem.


If the problem occurs on Video only material the only change between 3.0.3 and 3.0.4 that I can see that would be relevent is the change in the default SleepInterval setting from 0 to 1. This was done to increase responsiveness of the GUI. Looks like it may well screw up the picture on some machines.


Could you try running version 3.0.4 with


[Threads]

SleepInterval=0


In DScaler.ini and see if it cures the problem.


If not then I'll have to go back to the drawing board.


Thanks


John
 

·
Registered
Joined
·
174 Posts
John,


I downloaded 3.0.4 and did as you suggested. Changing SleepInterval from 1 to 0 seems to have cured the problem. I now have a toggle for judder! :)


Thanks.


---
 

·
Registered
Joined
·
9,884 Posts
People sometimes want to raise the priority of DScaler video processing but this gets into trouble. I think that's why some folks thought you had to set Sleep_Interval=1, because otherwise you might have a long wait for menu response.


I actually always run with Sleep_Interval=0 but with the video process at very low priority so it will gracefully yield whenever the CPU is needed by anything else. And the DScaler menus have to run at a higher priority than the video. When you click on something you want it to pay attention.


- Tom
 
1 - 16 of 16 Posts
Status
Not open for further replies.
Top