AVS Forum banner
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
329 Posts
Discussion Starter · #1 ·
Normally, channel 12-1 is PBS out of philly, it get good signal strenght

channel 29-1 is Fox, again good signal strenght.


My unit for some reason shows's 12-1 as "weak signal" so when I

go ot the menu to check the signal strenght now, it shows a strong

signal and the video displayed is that of 29-1!


FYI - I have an additional receiver in the house which picks up both

fine.


Any ideas?


Aceman
 

·
Registered
Joined
·
1,172 Posts
Sounds like one or both stations are sending bad PSIP and cuasing the DTC-100 to get very confused. Try tuning to the "REAL" channel for both stations and see if it clears up.
 

·
Registered
Joined
·
329 Posts
Discussion Starter · #5 ·
Guys,


Here's what I've done to date...


unplugged it for more than one hour

rescanned w/ no antenna plugged in

rescanned w/ antenna


still same problem.


Now, I have another DTC 100 in the house, am using that one temporarily in the same setup, it works fine.


I called thompson, they are sending me a replacement unit, no charge.

They think there's something flaky w/ the tuner (duh!). All in all, I

found their customer service to be great.


Aceman
 

·
Registered
Joined
·
6,232 Posts
Just curious, what are the REAL channels you are after? Have you turned off the PSIP? I dumped that long ago, I have no need to call 41-1 7-1. Plus my DTC 100 always received 41-2 sub channel fine, but once re-mapped to 7-2 it showed "Weak Signal".


Go into the menu and disable the "Get OTA Guides", do a rescan and let us know what you get then....
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top