AVS Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Sorry if this is in the wrong forum. I have a MyGica HDTV Converter box that I hooked up to my monitor. When I turn it on it says "Digital TV Tuner" for a second then goes to the channels. However I only get three channels and I'm pretty sure they are all analog. They are labelled A4, D6-1 SBS, and A21. When I select either A4 or A21 it comes up with the channel and says ATV21, which is why I think they are analog. A4 has a caption saying "Press any button to continue" which just moves around the screen. A21 is a local channel and D6-1 SBS is just black.


The only significant menu options are the Antenna tab, which has Cable and Antenna selections inside of it and the Cable System tab which has Standard, HRC and IRC in it. I've tried fiddling around with all of these with no luck.


Anyone have any idea why I'm not getting any Digital channels? Is this just a really crappy Digital Tuner? Also there's a red light on the front with the letters "STUS" next to it. I don't have the manual so I'm not sure what that's all about.


Thanks.

Chris
 

·
Registered
Joined
·
10,873 Posts
You'll probably have better luck posting in the HDTV technical or general HDTV sub-forum.


But to help out, you need to tell us 1) where you are, 2) what's the programming source (off-the-air or cable).


Look up on antennaweb.org for your area and see where the channels are for OTA, that may help explain what you're seeing.


Jeff
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top