AVS Forum banner
Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I looked in some FAQs and search these here forums but either couldn't understand the answer, or didn't find what I needed.


I have a cablemodem (comcast broadband) hooked to a netgear router, and my computer(s) and replay5040 hooked to that router.


The problem I am having is that the xfers from the replay to my computer are being capped at ~30KB/sec.. same cap as the cable modem. I am wondering why the xfers care about the cablemodem cap at all. Other xfers I do (between my two computers, for instance) just pass through the router at top speed.


Thanks for any help.
 

·
Registered
Joined
·
145 Posts
Are you using DHCP on the Replay? If so, it may be getting an IP assigned by your cable provider's DHCP server and not your router's, causing what you are experiencing.


It sounds like your two PCs and your Replay are all on the same physical network segment (plugged into the same router), so next step is to ensure they are on the same logical segment (subnet.)


Other than a misconfigured network, there is no reason your Replay would try to talk to your WAN (cablemodem) when transferring files over the LAN.
 

·
Registered
Joined
·
1,799 Posts
Quote:
Originally posted by negamit
I looked in some FAQs and search these here forums but either couldn't understand the answer, or didn't find what I needed.


I have a cablemodem (comcast broadband) hooked to a netgear router, and my computer(s) and replay5040 hooked to that router.


The problem I am having is that the xfers from the replay to my computer are being capped at ~30KB/sec.. same cap as the cable modem. I am wondering why the xfers care about the cablemodem cap at all. Other xfers I do (between my two computers, for instance) just pass through the router at top speed.


Thanks for any help.
It's possible the RTV has a public (not private) IP address and as a result, all traffic to it is being sent up and back down the pipe.


Check the RTV and your PC. Both should have addresses that begine with 192.168.*.* or 10.*.*.*. If it's something else, that is the problem.


Solving that depends on a number of things on your network - do you have a DHCP server, can your router enable NAT and firewalling, etc, etc - more that can be covered here.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
I misspoke before. My units (2 computers and replay) are not plugged to a router, I have a netgear switch (FS605) that has allowed me to get multiple computers on the same broadband connection. I've been using a software firewall (zonealarm) for security.


The IPs on the two PCs are in the same subnet (255.255.252.0)


the IP on the replay is not.


Grasping at straws, I tried to manually change the replay, it won't accept the gateway that the PCs use.


One of my PCs is running XP Pro.


I will try and find more information on my cable modem.


Thanks a grand for your help.
 

·
Registered
Joined
·
348 Posts
Update the subnet mask on your PC's to 255.255.255.0
 

·
Registered
Joined
·
24 Posts
Keep the Ethernet switch.


Keep everything plugged into it.


Go to CompUSA/OfficeDepot/Buy.com and buy a cablemodem router. (i really don't care that everything is mostly working now and you'd rather not spend the $49.95, this WILL solve your problem! (as well as securing your computers a little better, and maybe even prevent your computers as being used as spam relays in the future))


Plug the router into your cable modem.


Plug the switch into your new router. if you want DVarchive to work wonderfully, it has been my expericence that the replayTV and the computer(s) running DVarchive have to be pulgged into the same ethernet switch, so Don't plug the replay into the new cablemodem router and leave the computers plugged into the switch.


Turn on USE DHCP on all of the computers and the Replay.


Turn off the "share this internet connection" on one of your PCs


You can probabaly disable the firewall stuff on the PCs, hiding them behind a router makes you pretty secure. On 2nd thought, PCs get infected faster then a 4yr old at preschool, so better keep it on.


Stop paying your cable company for the 2nd IP address.


I'm sure i left something out, I'll edit later when/if I remember anything more.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
quartrj, I will need to research that avenue. I will see what happens I manually set the IPs on all my machines. Right now, I think the 255.255.252.0 is necessary. The gateway is xxx.xxx.148.xxx, the PCs are xxx.xxx.149.xxx and xxx.xxx.151.xxx. I believe the "252" triple is allowing me to work with all them addresses.


Thank you for your suggestion, FreeBrian.


I don't mind spending money on more hardware (cable-modem router). But I would be a fool to not research other options first, no? My anxiousness regarding adding a router into the mix is that it will complicate my entire setup. Just something more to deal with when getting a new game, running a new server, icq, etc, etc.

Quote:
Turn off the "share this internet connection" on one of your PCs
I don't understand the reasoning behind this. Could you explain it further?


Cheers!


ps. I am pretty confident in my zonealarm provided security. the computers discard any incoming traffic that I haven't previously allowed. i think it's slick.


pps. I don't currently pay for additional IP addresses. MediaOne/ATTBIS/Comcast has never had a problem with me, possibly because they can't 'see' my computers anyway.


ppps. Of course, now I am at work, so I can't really do any of this stuff right now. :)
 

·
Registered
Joined
·
145 Posts
negamit,


You don't have to buy a router nor shrink your subnet to make this work.


But I'm not sure at this point how your gateway is set up. Are you using 2 NICs in one of your PCs, and is the other PC using private (192.168/16, 10/24, or 172.16/16) IP space?


Or are both your PCs using public address space, and using the same gateway address provided by your cable provider?


This makes all the difference in how you will have to setup your Replay on the network.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #10 ·
The two PCs each have one NIC. They both are using the same gateway provided by the ISP's DHCP. The two PCs are using a gateway beginning with 66.


The replay is also set to get info from the DHCP, but it's getting a different gateway (and therefore IP). It's gateway starts with 24.


all units are plugged into a switch feeding off the cable modem.


random troubleshooting i've done: setting the replay's gateway to the same as the PC's didn't work for me: 'couldn't find gateway'. setting PC's gateway to the same as the replay's also did not work.


I do understand that the problem is that the units don't believe that they are on the same LAN. I do understand that a router would fix this, but avoiding that would also be nice.
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top