AVS Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter · #1 ·
I have been trying to get DVArchive installed on my sister's W2K Pro computer (proud owner of a new replay!). I have the same setup at home and works fine, but when I try to get it to work on her's I keep getting an error message from the java virtual machine launcher when starting DVA. The error is:


"Could not find main class. Program will exit".


I have read the readme and even used the link on the sourceforge faq page to ensure I was using the correct version of java (1_4_1_02). I have also made sure there were no previous versions of java installed before starting.


Could someone help me try and figure out how this works so I can "get out of the doghouse"? It's not as bad as if it had been a wife instead of a sister, but I did ALOT of bragging on how great DVA is and if I can't get this to work, there is going to be "a hanging"!


Thanks in advance,


Jay
 

·
Registered
Joined
·
1,799 Posts
Quote:
Originally posted by grover517
I have been trying to get DVArchive installed on my sister's W2K Pro computer (proud owner of a new replay!). I have the same setup at home and works fine, but when I try to get it to work on her's I keep getting an error message from the java virtual machine launcher when starting DVA. The error is:


"Could not find main class. Program will exit".


I have read the readme and even used the link on the sourceforge faq page to ensure I was using the correct version of java (1_4_1_02). I have also made sure there were no previous versions of java installed before starting.


Could someone help me try and figure out how this works so I can "get out of the doghouse"? It's not as bad as if it had been a wife instead of a sister, but I did ALOT of bragging on how great DVA is and if I can't get this to work, there is going to be "a hanging"!


Thanks in advance,


Jay
Sounds like you may have the old MS JVM on there too. Try opening a command prompt and typing "java -version". If that works, then "cd" into the directory you installed DVArchive in and type "java -jar DVArchive.jar". If that works, then you have another JVM (probably the Msoft one) and you'll need to deinstall it and the Sun Java, then reboot and then reinstall the Sun Java.
 

·
Premium Member
Joined
·
4,316 Posts
You may want to also check in IE Tools | Internet Options | Advanced down a bit and see if it shows the MS Java and the Sun one. If you don't have the Sun option there and it's not checked, you aren't running the Sun java.


(I expect Gerry's method will work also... :) )
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #4 ·
____________________________________________________Sounds like you may have the old MS JVM on there too. Try opening a command prompt and typing "java -version". If that works, then "cd" into the directory you installed DVArchive in and type "java -jar DVArchive.jar". If that works, then you have another JVM (probably the Msoft one) and you'll need to deinstall it and the Sun Java, then reboot and then reinstall the Sun Java.

____________________________________________________


Well, that got me on the right track Gerry, THANKS! I uninstalled the MS JVM, installed the Sun Java, then executed the commands you showed in your reply. DVArchive finally ran, and the java version now shows the Sun version. However to be able to run DVA from the start menu, I still had to go in and do an "open with" and point it at "javaw" (was never available before in the program list) then check the box to always open this file with this program. TADA! Works great now.


And by the way Lee, I tried your way first cause it sounded the easiest, but the option for using the Sun version of java was not available at all in IE until I removed the MS JVM and installed the Sun version. Something about SP4 and W2K and I do remember loading DVA on my W2K box before putting in SP4.


Thanks Again Guys!


Jay
 

·
Premium Member
Joined
·
4,316 Posts
Great, glad it works. All the Win2K SPs little changes are a pain, hm? :)
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top