AVS Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I just bought the dvb318 from amazon and I have a Dec 2003 build date so I know for a fact it is capable of upconverting to 1080i via component video. When I hooked it up to the rca and try to upconvert to 1080i the tv screen flashes goes black and then for a few seconds I see what appears to be the dvb318 menu screen that has jagged lines and the picture will not come through. After a few seconds it will flicker and return to I guess its normal mode say 480i or something...and the dvb318 menu will come back but it is definitely not a good picture..its fair..but nothing close to HD. The tv actual does this with all the upconverting modes whether it be 480p/720p/1080i...any time I press the upconverting button the tv just does not want to accept it. This rca rptv has a built in hdtv tuner and is capable of 1440 X 1080 lines of resolution! What am I doing wrong? Could the tv be conflicting with the deinterlacer of the dvd player? Help! Thanks in advance.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
Seems like the 9 people who have viewed my concern do not know how to help me....is anybody out there that can give me some advice? I did a search on my two hardware items and found like 2 posts...both were from JGard...he has or had the exact same tv & dvd set-up...I pm'd him but no response as of yet....are u still around JGard?


Tell ya what...if no one knows what my problem is then maybe someone can just recommend what the best dvd player would be for my set RCA P61310. Keep in mind it does not support dvi/hdmi...only component. So much for the DVB318 being the best for my set :mad: the faster the response the better as I will be forced to return the Zenith if I cannot get it to work with my RCA. I am leaning toward the dvd-2900...I dunno! Thanx
 

·
Registered
Joined
·
302 Posts
Just some general observations in reference to at least the player and connection. I'm not sure about the RCA but some t.v.s have two component inputs and only one can be labeled as HD 480i/480p/720p/1080i. The other could be simply 480p max. Make sure there is or is not a distinction between the two and of course make the appropriate connection. When setting the player to 1080i, you can only do it when the player is in stop or when the tray is open. Everytime you make the selection the player will read what you selected 480p/720p/1080i and at everytime it changes the t.v. screen goes blank indicating the mode you last saw on the player's display. If the problem persists, try uplugging the player and plugiging it back in hopefully it will works itself out. P.S. a word of advice, your opening comment about 9 people who have viewed my concern do not know how to help me... can turn some people off hence delay anticipated responses. Just a thought. Hope this helps.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Romeo...thanks for the reply. I will address your last part 1st regarding the 9 people thing. That was in NO WAY meant to be an insult or a rude comment...trust me...this forum has been awesome...geez I think I'm 2 steps away from getting my a/v masters degree from all this info I get from here...its great! It was a 100% concern on my part. I was concerned that if 9 people have already viewed my post and didn't know how to help...then I was in trouble...I had a problem that is most likely unfixable. I apologize to anyone that may have taken that the wrong way.


As far as my TV goes...it only has one set of HD component video inputs which are capable of 1080i well suppose to be capable of that I should say...because obviously I cannot get the Tv and the player to sync up in any format for that matter. I have tried the unplugging thing and switching cables many x's with no success. Maybe its a HDCP thing going on...but as far as I know a Dec 2003 build date on the dvb318 should not have hdcp over its component outputs..I know the dvi output does...but that I need not worry about cause I do not have dvi input. The rca isn't hdcp over component aswell...so I highly doubt that is the issue. I have went over every setting in both menu systems...I cannot for the life of me find what the problem is. I did bring it over to my buddy's place and had it up and running on his Toshiba 65" hd monitor via dvi and the picture was awesome! Over component the pq was not so good...but maybe that had something to do with the fact that his set needs a external ATSC tuner 1st. I think the only person who may be able to help me here is Jgard..if he is still around. He had the dvb318 up and running on the same exact rca set. I hope he can help me. Thanks again
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Good news!!!:D I just solved my dilemma. Since I live in MI near the US/CAD border I headed to Future Shop in Windsor and found an LG DV7832NXC which we all know is the exact same player as the Zenith. I rolled the dice bought it and took it home...hooked it up to the rca and VIOLA....1080i is coming through nicely..PQ is very nice! So I will be returning the Zenith as it must have something wrong with its component outputs.


I have a question...would the dvd-2900 be an improvement over the LG (2900 @ 420p vs the LG @ 1080i...both over component) or should I just go with what I have. I paid $200 US for the LG and I have an opportunity to buy a NEW 2900 for around $580 US. All advice is appreciated.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top