AVS Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
5,701 Posts
Discussion Starter #1
One of my Echo extenders has been stuck on the last beta firmware version 2013.320.1349 since Ceton put it out and then pulled it nearly a full year ago. I couldn't update to the latest stable version 2013.304.1657 because the beta version I had was newer.


This Echo unit is located in my bedroom. Last night I fell asleep with the Echo playing live tv and woke up this morning to a black screen. The display worked for menu items and the guide, but the picture for any playing video was black. This happened several times before and I know the only way to get the picture back is to restart the Echo. From the task menu on the start screen I turned off the Echo, then used the green button on the remote to turn it back on. When it started up I got the extender pairing screen with the 8 digit code. That doesn't happen very often but I have seen it before. I was about to pair the extender in WMC on the host computer when I noticed the line at the bottom of the Echo screen that said there was an update available and to press 1 to update. I ran the update and got the older latest stable firmware version 2013.304.1657. After the update I had to pair the Echo with WMC, but I'm finally free of the buggy beta firmware!
 

·
Banned
Joined
·
2,696 Posts
My Echo that has the .320 firmware is currently occupying some valuable closet space.


My other Echo isn't stable enough to keep any firmware for very long. In the last month, it has auto-recovered for no apparent reason at all, three different times. Fortunately it is only used once or twice a week, so its flaky behavior is tolerable.
 

·
Registered
Joined
·
5,701 Posts
Discussion Starter #3

Quote:
Originally Posted by ajhieb  /t/1522493/echo-beta-firmware-rollback#post_24481139


My Echo that has the .320 firmware is currently occupying some valuable closet space.


My other Echo isn't stable enough to keep any firmware for very long. In the last month, it has auto-recovered for no apparent reason at all, three different times. Fortunately it is only used once or twice a week, so its flaky behavior is tolerable.
It might be worth getting that one out of the closet to see if it updates to a stable version.


I had one echo unit that would reboot and occasionally auto-recover. I opened a ticket with Ceton and after about a week of troubleshooting it got sent home RMA. The replacement unit they sent back to me is the one that was stuck on beta firmware for a year. My other two echos have been pretty good.
 

·
Registered
Joined
·
11,440 Posts
Quote:Originally Posted by ajhieb 

My Echo that has the .320 firmware is currently occupying some valuable closet space.

My other Echo isn't stable enough to keep any firmware for very long. In the last month, it has auto-recovered for no apparent reason at all, three different times. Fortunately it is only used once or twice a week, so its flaky behavior is tolerable.

It might be worth getting that one out of the closet to see if it updates to a stable version.

I had one echo unit that would reboot and occasionally auto-recover. I opened a ticket with Ceton and after about a week of troubleshooting it got sent home RMA. The replacement unit they sent back to me is the one that was stuck on beta firmware for a year. My other two echos have been pretty good.
So what was the final outcome of this?
 

·
Registered
Joined
·
11,440 Posts
That is a good question. It looks like you had three, one of which was on the 320 beta but reverted after a year to 305 so you now have them all on stable firmware. I guess I needed to address the question @ajhieb because something funky happened when I quoted that post in that it didn't include the original quotes correctly.
 

·
Registered
Joined
·
5,701 Posts
Discussion Starter #7
That is a good question. It looks like you had three, one of which was on the 320 beta but reverted after a year to 305 so you now have them all on stable firmware.
All three of mine are on FW 2013.304.1657. One is reliable, one is pretty good but it freezes up a few times a month, and the last one is a total POS. That last one freezes and/or re-boots itself every couple of hours and I can't get the stupid Ceton light to go out.
 

·
Registered
Joined
·
11,440 Posts
The only one that does this for me now is the android beta unit. Maybe I should just recover it but I like having it and once it's flashed it's gone.
 

·
Registered
Joined
·
5,701 Posts
Discussion Starter #9
The only one that does this for me now is the android beta unit. Maybe I should just recover it but I like having it and once it's flashed it's gone.
I tried to get in on the Android beta but I wasn't chosen. Can you side-load anything on the Android Echo? It would be great if I could use my Echos to run the HDHR DVR Android app.
 

·
Banned
Joined
·
2,696 Posts
Both my echo's are back in the drawer. I'm using XB360 slims everywhere now. The echo was simply too unreliable for day to day use. I wrote it off as a learning experience long ago. I have found the Echo USB power adapter makes a great phone charger and the remotes have helped in a pinch when the batteries died on my HP remotes.

Basically I've found a useful function for everything that came in the box except the Echo itself.
 

·
Registered
Joined
·
11,440 Posts
I tried to get in on the Android beta but I wasn't chosen. Can you side-load anything on the Android Echo? It would be great if I could use my Echos to run the HDHR DVR Android app.
Here's a link to the last of many test videos I sent to Motz and mikanho about 3 years ago. In this one, I am basically pleaing with them to not ax the program as I had my android echo playing videos fine using a side loaded app called Serenity for Android which is a Google TV (and some Tablets) front end for Plex. I also had MX player and the MX Neon dts decoder installed. The only problem was that each night the echo would clear the sideloaded apps and I'd have to re-install them the next day to continue testing but if Ceton had put in the f/w it would stick. I had this discussion with Motz..

It just could have been...

Here's one more.

Since this product is out of production, I think the NDA no longer applies..
 

·
Registered
Joined
·
5,701 Posts
Discussion Starter #12
It just could have been...
Here's one more.
That looks great. What Android version is it? I'd be willing to send my units back to Ceton and pay them to put a modern version of Android on them. If anyone has figured out how to do it on their own I'd love to learn how.

That last link is dead.
 

·
Registered
Joined
·
11,440 Posts
That looks great. What Android version is it? I'd be willing to send my units back to Ceton and pay them to put a modern version of Android on them. If anyone has figured out how to do it on their own I'd love to learn how.

That last link is dead.
This one?
 

·
Registered
Joined
·
11,440 Posts
One more..

I doubt that Ceton will do anything for you but if you do do that don't tell it was me!

LOL..

PS. Maybe now it is a little more clear why I was rooting for them so diligently. I couldn't say anything because of the NDA.
 

·
Registered
Joined
·
11,440 Posts
I posted clips of Star Trek, Amelie and finally Hugo.. Which ones can you not see? I'll try a different way to post them.
 

·
Registered
Joined
·
5,701 Posts
Discussion Starter #17
One more..

I doubt that Ceton will do anything for you but if you do do that don't tell it was me!

LOL..

PS. Maybe now it is a little more clear why I was rooting for them so diligently. I couldn't say anything because of the NDA.
I won't tell Ceton anything.

Your latest link leads to this:

Code:
https://*******/photos/Zv26H5QiiF75f2wQA
 

·
Registered
Joined
·
11,440 Posts
Try again. I changed the url.
 

·
Registered
Joined
·
5,701 Posts
Discussion Starter #19
I posted clips of Star Trek, Amelie and finally Hugo.. Which ones can you not see? I'll try a different way to post them.
The Star Trek one works. I didn't try the Serenity one. None of the others worked.
 
1 - 20 of 29 Posts
Top