AVS Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter · #1 ·
I have an Electrohome ECP 4100 and I'm trying to debug a tube issue with a minimum amount of projector disassembly. I'm trying to swap 2 driver boards and I'm not sure if the black wire that goes to the main tube socket on the board should be removed from the driver board or the other end of the wire (teminating somewhere in the projector that would require more disassembly). Can someone tell me which end this wire should be disconnected from? If it is the driver board end, can someone explain how this wire (or connector) should be removed (direction to pull, tabs to release, etc). Did a search but didn't find this info. Thanks in advance!

-Alan
 

·
Registered
Joined
·
594 Posts
Just came across this thread whilst searching for something else....I'm assuming you are talking about the neck boards on the back of the tube? If you haven't figured it out yet or if no one has contacted you then you do the following.

-Remove power.

-Follow the cable back and you'll see that it connects to a post underneath the bias module between the blue and green tube (one with the focus pots on it).

-Simply disconnect it from here and pull the cable back to the neck board.

-Take note of the order that the other three cables plug to the neck board. The small two pin molex and the multi pin one are no problem it's the three that slip over the single pins that can get installed wrong. Should take about 10 minutes to change out......
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top