AVS Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Premium Member
Joined
·
4,929 Posts
Discussion Starter · #1 ·
Guys,

It looks like I have a couple of toasted ECP HV power supplies. I've got a couple of questions.


1) Is there anything that inhibits the 34KV from coming on? (besides the power supply being busted). When I turn one particular unit on, I get an H INHIBIT LED and no static whoosh of the high voltage coming on. I've swapped *every* board in this thing. I was wondering if there's another problem that prevents the HV supply from coming up or if it should come up no matter what.


2) What kind of test equipment to I need to measure 34KV? I don't want to get near it without the right tool. I don't think my Fluke handheld or my scope will do it :)


3) When will Mike Parker say "go!" so we can start sending him our toasty HV supplies for repair? :)


Cary
 

·
Registered
Joined
·
1,390 Posts
I know that when Jay Wilson was using an ECP, he was playing with ECP HV PS repairs... it might be worth dropping him a PM to ask him about his success in HV PS repair... in the event he doesn't see this post.
 

·
Registered
Joined
·
6,833 Posts
Cary,

I have a ECP 3000 that is on loan until I retube a Marquee 8110. That 3000 will be used for the repair of the ECP modules. I should have that 3000 back soon, and at that point I'll start the repair for the ECP's.
 

·
Registered
Joined
·
6,833 Posts
Cary,

you might have a shorted power fet on one of the deflection boards. Check for a shorted power fet (TO-3) on each of the three deflection modules, you can do this with the modules in the set, by touching the probe to each of the six (6) fets from the rear of the set.


The H-inhibit indicator will illuminate when the high voltage supply is not working, or if the fets are shorted. Rule out the fets first.
 

·
Registered
Joined
·
2,861 Posts
I gave up on my HVPS. Chuck Williams (where has he been???) offered me one at a price I couldn't refuse. I had it all apart, with all the potting out and was in process of testing all the components. It appeared one of the diodes in the potting was bad. That was about the time Chuch PM'd me :)


I still have the old HVPS sitting here torn apart, I just haven't had the heart to throw it out and I've been rid of my ECP for a year now.


How you enjoying that Marquee Cary? :):):)
 

·
Premium Member
Joined
·
4,929 Posts
Discussion Starter · #7 ·
Thanks Mike! I suspected the deflection boards right off and swapped a known good one through all three (it would have been faster to use the scope though) :)


Jay, how do I like the Marquee!? Love it! I'll shoot you an email...


Cary
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top