AVS Forum banner

Status
Not open for further replies.
1 - 15 of 15 Posts

·
Registered
Joined
·
407 Posts
Discussion Starter · #1 ·
Could any Linux (specifically RH 7.3) experts please give me a hand here?


I've got the starts of a media server going, Athlon 1.4 on an Asus A7v266-E with 1gb PC2100. I have a 4gb ATA 33 drive on Primary Master, which is running fine. Using HDPARM I've got it runnig with DMA and UDMA 2 so no problems there.


However, I currently have two ATA 100 Western Digital 200gb drives attached to a Maxtor Ultra133 IDE controller card (One drive per channel, master in both cases).


I can't for the life of me get these drives out of UDMA 2 up to UDMA 5 where they belong.


using this command:


hdparm -c 1 -d 1 -m 16 -X 69 -k 1 /dev/hde (and hdg for the 2nd drive)


has no effect. On boot I get something like this:


VP_IDE:

ide2 ............... BIOS settings: hda: PIO hdb: PIO

ide3 ............... BIOS settings: hdc: PIO hdd: PIO


VP_IDE:

ide0 ............... BIOS settings: hda: DMA hdb: PIO

ide1 ............... BIOS settings: hdc: PIO hdd: PIO


i.e. the only drive it's picked up properly is the one with the OS on it. The BIOS of teh controller card picks up that the drives are UDMA5 however.


A little bit further into the boot process I get this:


ide 2: Speed warnings UDMA 3/4/5 is not functional

ide 3: Speed warnings UDMA 3/4/5 is not functional


this is part of the hdparm command set up to be run during boot.


Anybody got any sugestions please?
 

·
Registered
Joined
·
838 Posts
I am running RH 7.3 with a CMD649 4-port ATA card (I forget the brand name). I have all my drives at udma5 (ATA/100 I believe) with no problems.


Don't worry about what the IDE controller reports as the speed in your dmesg. Mine also shows PIO which is not correct. Look a few lines down for lines like this for each HD:

hda: xxxxx sectors (xxxx MB) w/xxxKiB Cache, CHS=xxx/xxx/xxx, UDMA(100)

All my drives show UDMA(100). Also you can run hdparm -i /dev/hdX and look at which udma setting has a * next to it.


If you really don't have udma enabled, try running simply:

hdparm -d1 /dev/hdX

and see if that works. I believe this should enable DMA at the max speed your drive supports.
 

·
Registered
Joined
·
407 Posts
Discussion Starter · #3 ·
sorry, should prob have put everything I've tried. There's a * against UDMA 2, when doing hdparm -v -i /dev/hde (and hdg) and I've tried many tmes forcing it to ATA 100. the command gets accepted, but is still sitting at UDMA 2 :(


It's definitely not soemthing that can be corrected using hdparm.
 

·
Registered
Joined
·
838 Posts
Hmm, that is strange. Those "speed warnings" messages during bootup are probably the problem. Search google for those and you might find some other things to try. You could also look specifically for info about your Maxtor card and those errors.
 

·
Registered
Joined
·
918 Posts
It's possible RH 7.2 may not be fully supporting your Maxtor Ultra133 IDE controller. Find out info on your pci bus and then try a google search.

# lspci -v


A quick (and simple h/d test)

# hdparm -tT /dev/hde
 

·
Registered
Joined
·
407 Posts
Discussion Starter · #7 ·
hmm, lspci -v brings up (amongst other stuff):


00:0c.0 Unknown mass storage controller: Promise Technology, Inc. (rev 02)

(prog-if 85)

Subsystem: Promise Technology, Inc. : Unknown device 4d68

Flags: bus master, 66Mhz, slow devsel, latency 32, IRQ 10



then various I/O ports and memory sizes.


This brings up two thoughts:

1) repeated 'unknown device' mentions - looks like you may be right about driver support.

2) It has a 66Mhz flag. I saw something about assuming 33Mhz in the boot up. Might that be relevent?


Agtiny: that's pretty much been the focus of my searches, problem is I have found nothing relevent with teh Maxctor (or promise equivalent) cards, and a massive quantity of unhelpful material using that error!


Cheers, peeps.
 

·
Registered
Joined
·
838 Posts
I think the Promise cards are supposed to have good drivers. Make sure you are compiling every Promise driver you can into the kernel. Do the Promise or Maxtor websites mention Linux at all?


Also in the command you listed in your first post I noticed you were using -c1, but you might want to try -c3 (32-bit sync mode).
 

·
Registered
Joined
·
407 Posts
Discussion Starter · #9 ·
agtiny, you might be right, I had another look at the promise site, and how I missed it befroe I don't know, but there's a patch available for teh kernel versio I'm using.


So, I've patched teh kernel, configured it and recompiled it. No noticable difference whatsoever. Hmm. Mind you, the likelyhood of me having done something wrong is pretty high cso that's teh first time I've recompiled a kernel! Seemed to boot ok from it though.


I've decided that my next step will be to start from scratch. I want to do a few other changes that I've learn't over the last few weeks, one of which is that noone uses grub, so I'm gonna swap over to LILO!


I have tried -c 3 btw, tried just about everything in hdparm :D


I'm not there yet, but I think I know what needs to be done...
 

·
Registered
Joined
·
407 Posts
Discussion Starter · #11 ·
I *think* I've seen that thread before. But noone on another forum could tell me how to get grub to do exactly that. Grub docs unfortunately seem rather weak. One of the reasons why I'm gonna start from scratch and use LILO now! The problem with that is that there's no follow up saying that it was a succesful fix.


Cheers :)
 

·
Registered
Joined
·
838 Posts
I just looked and I'm running grub too on my RH7.3 box. I checked the info pages (info grub) and it looks like all you have to do is edit /boot/grub/grub.conf and add those ideX=ata66 lines at the end of the kernel /vmlinuz line! Then you just reboot. Something like this maybe:


title Red Hat Linux

root (hd0,0)

kernel /vmlinuz-2.4.18-3 ide2=ata66 ide3=ata66
 

·
Registered
Joined
·
407 Posts
Discussion Starter · #14 ·
You sir are spot on! Just added that extra to the grub.conf and bingo it's working! I decided to go for excatly as you put, and use =ata66 rather than ata100 as I thought that if it worked in 66 I'd then see if ata100 was supported too, but it's gone into UDMA5 anyway, so I'm sorted :D


There's some messy messages about it being forced into that mode and stuff, but I guess I can live with that.


Think I'll still go for a new install thoug, as the thign is in bit of a mess now...


one happy nutcase :)
 
1 - 15 of 15 Posts
Status
Not open for further replies.
Top