AVS Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
677 Posts
Discussion Starter · #1 ·
After one year of no problems with my 6010, unit wont start. Power light is blue and the light below it ( ceiling mount) flashes blue. I pulled the a/c power a couple of times in hopes it would reset but no response. Fan is running and the lens cover does not open. Any ideas other than getting a replacement from Epson?
 

·
Registered
Joined
·
1 Posts
Having the exact same problem, got mine last July. Any help from anyone? I tried powering it up via the projector power button, changed hdmi cables, switched power outlets etc. etc., all to no avail. Ideas? Thanks!
 

·
Registered
Joined
·
2,766 Posts
I'm getting the same problem on the THW-9000H (The 6010 I think?) in Australia. It has done it once or twice before, but it won't start now.
 

·
Registered
Joined
·
7,005 Posts
It sounds like your projectors are hanging up during the boot-up process. Calling Epson customer service and getting a replacement is probably the only course of action at this point.
 

·
Registered
Joined
·
2,766 Posts
This is my third projector, each one starts off fine, but eventually starts doing this.

The latest one is on 1.08 firmware and yesterday I left it with the flashing light for the entire day and it didn't start up. I turned it off after about 8 hours.

Tried it again multiple times with the same result.

This morning I turned the main power switch on and let it sit for ten minutes before pressing the soft 'on' switch. It worked okay today.

My warranty is nearly up and I am worried I am going to be stuck with a lemon.
 

·
Registered
Joined
·
1,177 Posts
I've had the 5010 for a year and a half and I haven't gotten that problem, but I'm a little worried.


Would it be a good idea to conduct a poll among users of these units to see the percentage of people with this particular issue?



Could a bad bulb trigger a problem like this?
 

·
Registered
Joined
·
17 Posts
I am having the same problem with my Pro Cinema 6010. It is under warranty and Epson says they will replace it with a refurbished unit. Refurbished units always concern me, feel like I'm getting someone else's problem. Do I need to be concerened about the quality and appearance of a refurbished unit from Epson? I would hate to have my pristine unit replaced with a marred and scratched device. I am very fussy about the appearance of my equipment.
 

·
Registered
Joined
·
11,586 Posts

Quote:
Originally Posted by hslansky  /t/1472179/epson-6010-flashing-blue-light#post_24056640


I am having the same problem with my Pro Cinema 6010. It is under warranty and Epson says they will replace it with a refurbished unit. Refurbished units always concern me, feel like I'm getting someone else's problem. Do I need to be concerened about the quality and appearance of a refurbished unit from Epson? I would hate to have my pristine unit replaced with a marred and scratched device. I am very fussy about the appearance of my equipment.

I would stress to Epson that you want a refurbished unit that is not scratched and dinged up. Honestly, some refurbished units are pretty much brand new (as is it never even left the factory and had to be classified as "refurbished" until it went through additional testing). And some units are going to be returns that could have wear and tear on them between the users and techs working on them.


Epson customer service is quite good, it could not hurt to request a new looking projector.
 
1 - 9 of 9 Posts
Top