AVS Forum banner
Status
Not open for further replies.
1 - 19 of 19 Posts

·
Registered
Joined
·
316 Posts
Discussion Starter · #1 ·
I was looking at FlipFlop's site just now for a Mac OS X version of Extract RTV and did find one for Linux PPC but, none for Mac OS X. Is it possible to use the Linux version since Mac OS X is based off of Unix? Any chance someone has a Mac OS X version? Also, can someone recommend a good Hex Editor for Mac OS X? Finally, the link to the RTVPatch OS X beta version doesn't work. Anyone have a working copy of this program?

Thanks in advance for any help.
 

·
Registered
Joined
·
731 Posts
Fink doesn't maintain extract_rtv. That'd be silly. You could try download the LinuxPPC source and compiling it on your Mac. [The Linux binary won't "just work."]


If he's feeling magnanimous, I suppose FlipFlop could port it to Darwin, but that's up to him, really.
 

·
Registered
Joined
·
20 Posts
I just used MadSkeelz's RTVPatch_OSX and it worked perfectly.


I just went from the 30gig drive to the Maxtor 160gig drive.


One little issue in the terminal with permissions, but once that was changed, it went perfectly.


videovideo
 

·
Registered
Joined
·
731 Posts
You're welcome, but I did nothing but provide the development iron. FlipFlop [and the other developers of RTVPatch] get all the credit.
 

·
Registered
Joined
·
731 Posts
Ok, I'm thoroughly embarassed.


Whilst trying to help videovideo with her patchin' troubles, I started reading through a bunch of email FlipFlop and I exchanged in October.


When RTVPatch was ported to X, FlipFlop also ported extract_rtv. And left a copy on my hard drive. I guess we all just forgot about it [and certainly forgot to post it publicly].


I've zipped and attached the binary to this post. And I promise to increase my already herculean caffeine intake.


Sheepishly yours,

 

extract_rtv.zip 15.978515625k . file
 

Attachments

·
Registered
Joined
·
20 Posts
after launching the extract rtv, what do I need to type into the command line?

typing just "-l" for show program descriptions or any of the other options gets me "command not found" and

adding the ~/Desktop/extract_rtv I get "Missing name for redirect"

Do I have the device name incorrect? Or something else...


(Sorry I'm so not a unix geek)
 

·
Registered
Joined
·
731 Posts
extract_rtv doesn't have an interactive menu interface like RTVPatch. Note the top line of output that starts with "USAGE". Basically, you have to type the full program name before each command. To perform a directory listing, type:


% ./extract_rtv /dev/disk1 -l


Don't include the angle-brackets in your command.


To extract all files:


% ./extract_rtv /dev/disk1 -e
 

·
Registered
Joined
·
20 Posts
It's not seeing my drive.

Could there be a difference between Replay drives and Panasonic ShowStopper drives?

Or is it just me, not being able to figure out what the actual device name is?

I tried the command "Users/bt/Desktop/extract_rtv -e" which should auto detect the drive but it came back with Didn't Detect any ReplayTV drives connected to the system."


(when I try "./extract..." I get the message "command not found")
 

·
Registered
Joined
·
731 Posts
It's very likely extract_rtv's autodetect function doesn't work in OSX. Personally, I've never used it, since I have a 4000.


It could be a permissions problem, try running extract_rtv as root by preceding your command with 'sudo'. Also, just plod through the disks one-by-one. /dev/disk1, /dev/disk2, etc. extract_rtv just reads from disks, so it probably can't cause too much trouble.
 

·
Registered
Joined
·
20 Posts
nope, I get "Unable to open drive image file: No such File or Directory"


I'm just gonna watch all the programs I have recorded and then swap the old drive for the new bigger one.


thanks for all your help, I really appreciate it.


sb
 

·
Registered
Joined
·
95 Posts
It's not really clear to me from the notes on SourceForge...does RTVPatch for X (2.3 beta) support large drives, and does it support FireWire drives? I know that 2.4 does, but that's not available for X. I like the idea of being able to prep a big RTV drive with my PowerBook...


Thanks,

Ivan.
 

·
Registered
Joined
·
731 Posts
I think FlipFlop and I decided that as long as the mounted disk shows up as /dev/diskN, RTVPatch should work. I was able to successfully patch my iPod. Of course, I couldn't actually test it in the Replay, but RTVPatch seemed happy with its results.


Large drives are a different matter though. I'm just guessing, but as long as your ATA controller supported large drives, I would assume RTVPatch would. Give it a whirl, and let us know how bad things break! :)
 

·
Registered
Joined
·
95 Posts
Next time I get a big HD, I'll let you know. CompUSA has WD 7200RPM 8MB for $239 AR, tempting tempting...


I wouldn't necessarily guess that RTVPatch 2.3beta would work with large drives even if the ATA controller supported it, because, at least on the Windows side, large drives weren't supported in version 2.2.x. You were supposed to use version 2.1.3beta for those instead. However, the new version 2.4 supports large drives again, and I happily just used it on my new 250GB Maxtor... Anyway, I'm not sure about the status of 2.3. Maybe I'll wander around sourceforge and look at some, you know, source...
 

·
Registered
Joined
·
20 Posts
I just used RTVPatch_OSX for a Maxtor 160GB hard drive I bought from Dell. It was $155.00, online.


It showed up as 138GB in the disk info list, but I think I've got all 160GB available in the Showstopper.
 

·
Registered
Joined
·
316 Posts
Discussion Starter · #18 ·
madSkeelz,

Thanks for the link to the X version of extract_rtv.

Is the command line interface for extract_rtv under OS X the same as it is on Win2k/XP?

I ask because I need to be able to download my channel guide, edit it in a hex editor, and then upload the file back to the Replay drive. I've done this a lot in Windows but, have never done it under OS X.
 
1 - 19 of 19 Posts
Status
Not open for further replies.
Top