AVS Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
All,

I had my F38310(JX5) for 15mos without a problem (purchase date 11/01). Yesterday morning got up and turn the power on from remote, NOTHING. Pressed power button on the Panel, NOTHING. Also noticed Fan is not running. I didn't notice any symptoms at all.


Bad news is I have not purchased any extended warranty and now my basic warranty is expired. I called RCA rep and explained my problem and asked him if I can buy an extended warranty (DUH!!!), he told me to "get it fixed by paying from your pocket and call us and we will sell the warranty".


What should I do now? How much I am expecting to pay from my pocket? What are my alternatives? I live in Northern Virginia area. Can anyone PLEASE suggest a place and/or tech who worked on this before. Please fellow F38310'ers HELP ME.


I really appreciate your help. Any suggestions is really appreciated.


rt
 

·
Registered
Joined
·
3,175 Posts
Have you tried unplugging it for about 1/2 hour then re-plugging it. I had an instance a month or so ago when I couldn't turn mine on, either by remote or the front panel buttons. I don't recall if the fan was working or not. I called Circuit City for service. I had first unplugged the TV. I went back 1/2 hour later and plugged it back in, and it was working beautifully. Haven't had a problem since. I cancelled the service call.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top