AVS Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
833 Posts
Discussion Starter · #1 ·
my external harddrive seems to have crapped out on me. I'ts just one data partiotion. I go to computer/manage- disk manager and it takes like 5 minutes to even show the drive. Windows can't access the external harddrive. It was saying I had to format it and was being reported as raw. I'm running test disk utility now- it couldn't see any partitions. I clicked further into deeper search and my read error count is just as high as analyse cylinder count. Does this mean testdisk isn't working or drive is faulty? after 16 hrs. using deepcheck on testdisk finally finished at %100 and went back to main page. I guess that means it couldn't find any partitions. I know there is a ton of data on this drive and I didn't do any destructive formatting. What I may have done wrong is unplug harddrive while it was spinning and maybe at the same time I asked windows to check and fix errors on the disk. I ran easus data recovery. It took a long time to start up obviously since it was trying to sync with my externnal harddrive. First I tried the full recovery option but the harddrive wouldn't show on the list so I did partition recovery. After 20 minutes of inteligent searching no files of any kind have been detected and the Remaining time is at 26 hrs. and keeps getting higher. The harddrive is only 500 GB. Should I take the 2.5 size hrdrive out of it's enclosure and put it in a spare enclosure I have. Are all portable hardrives able to remove hardrive?
 
1 - 2 of 2 Posts
Top