AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
331 Posts
Discussion Starter · #1 ·
I got my Optoma GT700, took it out of it's box, put two fingerprints on it, packaged it back up and sent it off on it's first Firmware RMA. That was 11/24 - the day before Thanksgiving.


I called for an update on my RMA status and the guy told me it shipped two days ago and gave me a tracking number. Yea! When do they ever update their website? Seems like it's only updated after a phone call IMHO...


So I just tracked the package, I was told it not due until the 13th however with it being the busy season, a lot of stuff is arriving WAY++ early from UPS lately. Not FedEx though, can't really fault them for what they're doing, but it's still a jerky kind of thing to do. They've had my package at the local depot for over 24 hours now. It actually got placed on a truck and then was pulled because it was still too early to deliver.


I guess they're just trying to time it for when I'm sure to miss the delivery and there'll be no one here to sign for it, lol...


 

·
Registered
Joined
·
42 Posts
At least it isn't Pilot. They were shipping me a 150 inch screen.


My last tracking info was Dec 3rd, confirmed on board.


Called them today, lady said it should be in a nearby city (Des Moines). She put me on hold and then came back and said DM didn't have it and she doesn't know where it is. She said she would call me back and never did.


I'll give them to Tuesday then I'll get a refund from amazon. Glad I ordered from amazon LLC so I don't have to deal with a 3rd party.
 
1 - 3 of 3 Posts
Top