AVS Forum banner

Status
Not open for further replies.
1 - 20 of 21 Posts

·
Registered
Joined
·
326 Posts
Discussion Starter · #1 ·
Hi all,


sorry for another ffdshow thread, but i have a few questions i hope some one can help me with


my setup


win XP pro


sonic cineplayer 1.5 filters


zoomplayer 3beta1


I have edited a zoomplayer graph by placing the "(ffdshow ax)" after the filter presume this correct.


I have entered the AllowAllRenderers in the registery


some one posted the following
Quote:
here's the settings i think work best for DVDS in ffdshow...(i suggest you get the newest alpha version of ffdshow dated 10-03-02)
which i did

Quote:
In the post processing section the ONLY thing you want enabled is Nic's postprocessing...i keep it at default...the effect is VERY subtle but i think it brings out a little detail in distances
I can't seem the find the Nic's postprocessing or default

Quote:
In the sharpen section i use unsharp mask at 45 and "process whole image is checked... (i like ALOT of sharpness, but that's just my preference)
I can't seem to find the process whole image. check box

Quote:
in the blur+nr section i use gradual denoise at 15....it's important NOT to check "process whole image", or you will get subtle distortions in moving stuff...
I can't seem to find "process whole image" check box


in fact i can't seem to find most of the thing that where mention, am I using the same programe is ther more than one?


also some one said the the mpeg 2 box in the codecs should be ticked, but mine is greyed out, can only select raw.


i selected to show the task bar icon but it does not show,

Is there any way to alter the ffdshow settings while zoomplayer is playing.

looked in the filters in the context menu but there's nothing there.


How do i know that ffdshow is working, the filters registed ok in zoompayer.


Any help would be appreciated :confused:


i have tried the search funtion but due to server problems it keep get turned off.


Steve
 

·
Registered
Joined
·
326 Posts
Discussion Starter · #2 ·
Just a little more info for the above,


Iam using VMR and the video plays back ok


steve
 

·
Registered
Joined
·
686 Posts
Hello,


you mentioned that you use the de-noise at 45 so I see that you know where the ffdshow attribute/property page is.


Nic's:


open post processing property page, Nic is in the lower left quater. Default values are 20 and 40


Unsharp mask:


Go to the Blur&Nr property page, on the top, middle-left there is a checkbox with "process whole image".


Unsharp:


Go to the Sharpen property page, on the top, middle-left there is a checkbox with "process whole image".


Feel free to ask further questions and good luck...
 

·
Registered
Joined
·
326 Posts
Discussion Starter · #4 ·
Hi frbie


not sure i can see them,

tried to post some screen shot to show what i see but was unable,

can i send you a small html file of my screens so you can tell me if they are the same as yours


could the fact that i can't select mpeg 1 and 2 ( both greyed out) have some thing to do with me not Seeing what you described.


thank for your input so far


steve
 

·
Registered
Joined
·
686 Posts
Hello,


here is a screenshot of my the post-processing property screen. Normally the MPEG theme could not affect the general properties (IIRC).
 

·
Registered
Joined
·
326 Posts
Discussion Starter · #6 ·
Hi frank,


no it is not the same as mine, i don't have those bits on mine


Steve
 

·
Registered
Joined
·
326 Posts
Discussion Starter · #7 ·
hi Frank,


could it be because i am use VMR, where did you get your version, i downloaded mine the other day so would presume that its a new version, got it from http://cutka.szm.sk/ffdshow/


by the way thanks for your time in helping me this


steve
 

·
Registered
Joined
·
686 Posts
Hello,


no the VMR could not affect this in such a way.


Please go to the ffdshow proterty page. Very low there is a theme called "About" - select this.


There are the credits and the version on the top. My version is from the 29th of November.


Normally you can download it here. Please select the latest alpha! But I don't see it there so here is the direct link to the latest version.
 

·
Registered
Joined
·
326 Posts
Discussion Starter · #9 ·
Hi Frank,

does a video (DVD) have to be running in order the alter the setting, like overlays,

it just seem strange that i have nothing below the processing strength, can't even get the task bar icon to stay its ok when the program is on the screen but when i select ok the program closes so does the task bar icon



steve
 

·
Registered
Joined
·
686 Posts
Hello,


when you want to change the settings through the Zoomplayer a film has to run. Otherwise you cannot access the filter propertiwhere you find ffdshow properties.
 

·
Registered
Joined
·
326 Posts
Discussion Starter · #11 ·
Hi Frank,


the version that you linked to has all the features, it all gives you more options at install (ie installs options for mpeg) than the one i was installing,

looks like this will solve my problem, but no doubt will give me some more,


Thanks again for your help.


steve
 

·
Registered
Joined
·
326 Posts
Discussion Starter · #12 ·
Hi frank


did you say that you can alter the setting by going the the filter properties in zoomplayer ( right click video in zoomplayer get context menu and filter prop are there with cineplayer video and audio etc)


if this is the case, i can not access the ffdshow filter properties from there because they are not there, ffdshow filter where registered


sorry to be a pain


steve
 

·
Registered
Joined
·
686 Posts
Let me chime in here...


When a DVD is playing, IF ffdshow is registered in Zoom, under "Context Menu (right click)--> filter properties " you should see something like "ffdshow MPEG-4 decoder". If it's not there, it's not in use. If the DVD is stopped and you are seeing the logo screen for Zoom, you can't access these filters.


You can also access ffdshow's properties via your start menu (I'm not sure if you've seen it already), Start-->Programs-->ffdshow.


BTW, in my setup I just have to check Raw Video for ffdshow to connect to the Sonic Decoder.
 

·
Registered
Joined
·
326 Posts
Discussion Starter · #14 ·
Thank Ricardo,


the ffdshow filter properties was not in the context menu, believe its my zoomplayer graph,


steve
 

·
Registered
Joined
·
686 Posts
Hello,


try this one.


DefineFilter(CinemasterVideo.DLL)

DefineFilter(CinemasterAudio.DLL)

DefineFilter(ffdshow.ax)

LoadFilter({70E102B0-5556-11CE-97C0-00AA0055595A},Video Renderer)

LoadFilter({E30629D1-27E5-11CE-875D-00608CB78066},Default WaveOut Device)

LoadFilter({9F062738-CD84-4F54-A3C4-BD5EB44F416B},Sonic Cinemaster® DS Audio Decoder)

LoadFilter({CD8743A1-3736-11D0-9E69-00C04FD7C15B},Overlay Mixer)

LoadFilter({04FE9017-F873-410E-871E-AB91661A4EF7},ffdshow MPEG 4 Video Decoder)

LoadFilter({D7D50E8D-DD72-43C2-8587-A0C197D837D2},Sonic Cinemaster® DS Video Decoder)

LoadFilter({9B8C4620-2C1A-11D0-8493-00A02438AD48},Source 0)

ConnectPin(Source 0,Video,Sonic Cinemaster® DS Video Decoder,Video in)

ConnectPin(Source 0,AC3,Sonic Cinemaster® DS Audio Decoder,Audio in)

ConnectPin(Source 0,SubPicture,Sonic Cinemaster® DS Video Decoder,Subpicture in)

ConnectPin(Sonic Cinemaster® DS Audio Decoder,Audio Out,Default WaveOut Device,Audio Input pin (rendered))

ConnectPin(Sonic Cinemaster® DS Video Decoder,Video Out,ffdshow MPEG 4 Video Decoder,In)

ConnectPin(ffdshow MPEG 4 Video Decoder,Out,Overlay Mixer,Input0)

ConnectPin(Overlay Mixer,Output,Video Renderer,In)
 

·
Registered
Joined
·
3,510 Posts
I've gotten ffdshow into my dvd playback stream on my gaming PC but can't seem to get past the line21 error on my HTPC.


I've made graphs in graphedit for sonic+ffdshow and they play there but my final graphs don't work in zoomplayer.


Something like "could not find destination pin X from line21 to overlay".


I have Allowallrenders 1 in Sonic 2.5 and RAW and MPEG2 are checked in FFDSHOW.


What am I missing here? Does it work on Win2k?
 

·
Registered
Joined
·
686 Posts
Jesse,


yes it works on W2K. Try UNchecking MPEG2, just leave it at raw. I had to do this in my work PC. Also, it's not enough to just set 'AllowAll...', you also have to set Sonic to Force Weave and disable it's Hardware Acceleration.
 

·
Registered
Joined
·
5,313 Posts
Quote:
you also have to set Sonic to Force Weave and disable it's Hardware Acceleration
No, you don't, at least I didn't set either of these and it's been working fine for me for a month or better. I'm using XP.


Vern
 

·
Registered
Joined
·
384 Posts
ZoomPlayer does not like this satement:


ConnectPin(Sonic Cinemaster® DS Video Decoder,Video Out,ffdshow MPEG 4 Video Decoder,In)


What should I do to get this to work?
 
1 - 20 of 21 Posts
Status
Not open for further replies.
Top