AVS Forum banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
912 Posts
Discussion Starter · #1 ·
After looking at all the long threads on FFDShow, I have noticed that most people seem to be using Intel systems. I, of course, have an AMD system, a Mobile 2600+ overclocked running at 2.3Ghz. I have it paired with an ATI 9800Pro video card attached to a Toshiba 57" RP HDTV. I have no problem playing HD material captured by both my FusionGold OTA card or my DVB-S card. However, using FFDShow brings my CPU to its knees.


I use ZP to play DVDs so I figured I would try FFDShow to primarily resize the picture but even at desktop resolution 1152x648 my cpu usage is at 90% (this is using Windvd 6 codec). If I try anything higher, I am peeking at 100% and studdering. Forget about 2x or higher resolution...


So my question is, should I forget about it because of my AMD or is there something else I should be looking for.


Thanks.
 

·
Registered
Joined
·
174 Posts
I have a mobile 2600 at 2.7 that does everything I want. I use denoise3d hq and lancosz to 1920x1440, with 5-tap lowpass deinterlacing when needed, and it keeps up fine. I am using Elecard decoders and VMR9, and the FFDShow OSD cycles between 50-100% cpu very quickly, doesn't drop frames, and no tearing.
 

·
Registered
Joined
·
723 Posts
A couple of things:


If you are not using any other filters other than resize, you may NOT be working in YV12 colorspace which will hog many more CPU cycles. You may need to activate another filter in ffdshow ahead of resize even if working "null". I use nVidia with VPP which automatically delivers YV12 input to ffdshow.


Also, ignore CPU consumption during trailers which are often video based material which will also suck up much more CPU than film based media.


DFA
 

·
Registered
Joined
·
8,926 Posts
I would agree with DFA. I use an athlon 3200+ that is not overclocked at all. I resize to 1776x1000 and it works just fine. However, I activate some of the filters before resize even if they are doing anything so that it does not hog my resources. I would definitely say that a decent athlon can be very affective with ffdshow and definitely a whole lot cheaper. Mine only cost $440 with a DVD burner.
 

·
Registered
Joined
·
912 Posts
Discussion Starter · #6 ·
I do use another filter before resize. My settings are as follows:


Blur and NR: - Denoise3d, Luma 0, Chroma 0, Time 5, HQ

Resize and aspect: Lanczos4, Luma .5, everything else 0

Output: YV12



I also tried Elecard (No CSS, No Sub) and for some reason when FFDShow is active I get a black box on the bottom 1/3 of the screen. Also when I play a 4:3 movie I get two video windows side by side.


With windvd codec the right video is green while the left plays the movie just fine. The Elecard plays the movie in both windows. All this goes away if I disable FFDShow. I am using the October 12 version.


A couple of other 16:9 movies seem to play ok with windvd codec but I have not been able to get the Elecard codec to play without that darn black box on the bottom of the screen (kind like a closed caption box but with no text).


Anybody have any ideas?
 

·
Registered
Joined
·
656 Posts
get rid of Denoise3d and just use gradual denoise instead. Then you should be able to use resize fine. Denoise3d in HQ takes a lot of horsepower - especially since you have both numbers set to 0, so its not even doing anything except eating up CPU.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top