AVS Forum banner
Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
hello folks!


i'm new here in this forum. just got linked from another site to here. perhaps you can help me! i did some search in this forum but i found nothing that solves my problem.


i use zoomplayer (v4.02) with windvd6 video codec and the ac3filter (v1.01a RC5) to play dvds (pal) and media files (recorded movies from the tv with my hauppauge pvr-350 in mpeg). now i've heard a lot about the ffdshow filter and i decided to test this one. i've downloaded the newest version (20041012) and installed it. then i intrgrated in the zoomplayer under dvd > dvd setup > additional filters. in the ffdshow config i deaktivated all codecs. just activated "raw video" with "all supported". although i disabled all ffdshow audio filters.


now the following happens when i try to playback


- media files: i just see the first frame, and only this one! the sound is playing but the video just shows the first picture. when i skip the video on the timeline 10 or 15 minutes further the video plays normal.


- dvds: two possibilities, i see a very disturbed picture and the sound plays or zoomplayer crashes. all pal dvds...


so what can i do to get zoomplayer with ffdshow working?


my graphics-board is an old matrox millenium g400 with the vga-rgb-scart cable.


plz. help me!
 

·
Registered
Joined
·
8,441 Posts
Quote:
Originally posted by digidroid
...media files: i just see the first frame, and only this one! the sound is playing but the video just shows the first picture. when i skip the video on the timeline 10 or 15 minutes further the video plays normal...
You need a null filter for FFDshow to work with WinDVD video codec.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #3 ·
what?

what is a "null filter"


digidroid
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #5 ·
hey guys...


i'm very sorry but i cant get it to work. it did some search in this forum and via google but i cant get ffdshow with zoomplayer to work...


can anyone give me a short step-by-step installation instruction how to ?


here the hardware/software facts:

- graphic-card: matrox millenium g400

- zoomplayer 4.02

- windvd 6

- ffdshow 20041012


and here what i want zoomplayer and ffdshow to do:

- playback of pal-dvds

- playback of mpg files (movies from tv which i recorded with my hauppauge pvr-350)


please help me...


digidroid.
 

·
Registered
Joined
·
94 Posts
a bug in ffdshow prevents PAL dvds from working. This can be fixed by getting the mpeg2 filter to send out the correct PAL resolution to ffdshow from the start.


This is done via a registry key. In windvd's case it is:

[HKEY_LOCAL_MACHINE\\SOFTWARE\\InterVideo\\Common\\VideoDec]

"DXVAPAL"=dword:00000001
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #7 ·
i set this already to dword:00000001


but in my registry this is not under HKEY_LOCAL_MACHINE. it's under HKEY_CURRENT_USER


but it has no effect. still the same problem! i just see a black screen. i hear audio and when i play with the timeline zoomplayer hangs up.



digidroid
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #9 ·
what is HKLM ????


by the way: you have a pm!
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #10 ·
uh! i understand HKLM... and i created it. but it takes no effect :-(
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #11 ·
ok, folks! thanks a lot!

i solved the problem with the dvd playback by fixing the HKLM!


but only the dvd playback. when i play my mpg files on the hard-disk i have the problem that i just see the first frame of the movie in zoomplayer but the sound ist playing. when i skip the timeline 5 minutes further i have picture and sound. so, how can i solve this problem?


oh, can anyone tell me where i can find the dmp abstact filter in the registry? i want so set him to "0".... oh, i just found it: HKEY_CURRENT_USER/Software/InterVideo/DVD6/Pasteurization/Intensity

to 0 right?
 

·
Registered
Joined
·
107 Posts
ok, folks! thanks a lot!

i solved the problem with the dvd playback by fixing the HKLM!


I guess you solved it with

[HKEY_LOCAL_MACHINE\\SOFTWARE\\InterVideo\\Common\\VideoDec] "DXVAPAL"=dword:00000001

correct? Always good to let others know what you did so they/I can learn.


By the way, this is one reason why I don't use FFDSHOW in my setup - I would have to set DXVAPAL manually all the time. I guess I can write a reg file, however, it's still a bother!
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #13 ·
so folks...


i just activated the libra in ffdshow unter the mpg1 and mpg2 codes. previously it was deactivated. now when i playback my mpg files from the tv-card i see the movie and hear the sound but both are stuttering all one or half seconds...


any ideas how to fix this?


dvd playback works fine now.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top