AVS Forum banner
  • Our native mobile app has a new name: Fora Communities. Learn more.

Firmware problems with E85?

760 Views 6 Replies 5 Participants Last post by  Rafael2K
I have had my Panasonic E85 for about 2 months. Generally, it has worked very well. I like the TV Guide, simple editing, dubbing to DVD-R all have no problems. But I seem to have another new problem every couple days. These problems don't feel like hardware problems but more of a problem with the firmware built into the unit.

Here's some of my problems I have seen:

* We were often getting the message when we turned it on "Error has occurred. Please press enter". The unit then went through a self-test operation and apparently everything was fine. Ultimately, we figured the problem was that the unit was in standby, actively recording a timer program, and someone hit the System-OFF button on the universal remote control. We have a universal remote with a macro button programmed to turn off all components. I have the discrete power-off code programed in the macro for the E85, not the power toggle code. This is not very nice behavior (it should just keep recording), but I think I have my family trained to check the Panny before doing a System-OFF of all components.

* Then a couple days ago, I got the same error message but no one did the System-OFF on the universal remote. The unit was recording a show at 3AM so I know no one disturbed it. In the morning the same error message was on the screen.

* One time, my wife was in the title navigation menu and the unit locked-up. She called me at work in a panic and I couldn't believe it wouldn't respond. When I got home, I found she was right. Nothing worked so I pulled the AC power cord. After a couple minutes it booted up correctly.

* On another occasion the unit would not come out of standby. When you hit the power button, the unit would briefly display something on its front panel and then turn off again. I disconnected the power cord and again that got it working.

Is anyone else having these kinds of problems with the E85? Is there a later version of firmware that I should get installed? If so, how do I tell what version I have? Could this really be a hardware problem instead?
See less See more
Not open for further replies.
1 - 7 of 7 Posts
I have had the same problem with the direct navigator. Twice I've had to unplug the unit to get it working again. Happened right when we got it, but not since (2 months now). Have had problems frequently when dubbing to DVD from the HDD that there is an "error" and it goes into self check mode. Not sure if there is a firmware update that can be done to correct these problems or not. I'm willing to live with them for now, DVD is so much easier to use that VHS tapes.
I would guess your unit is a lemon or has developed intermittent hardware problems and/or failures. This is not typical behavior...I would call Panasonic as soon as possible.

You may try formatting the Hard Drive, and doing a factory reset as per outlined in the manual.

You cannot upgrade the firmware yourself. AFAIK the only what the firmware can be upgraded is if you send it to Panasonic for repair and they replace a certain part.
Typically, when you are burning a disc and get the message "error has occured" and it goes into its self-check, reboot routine, it is something to do with the blank dvd that you are burning. I have seen this several times and using a different brand of disc or sometimes just starting over with the same disc, we resolve the problem...
I've had my E85 for about 8 months, and have experienced none of the described problems. In fact, I have had exactly zero recover errors or self-checks after thousands of hours of recording and about 300 or so burned DVD-R's. Knock on wood....
Please note that none of the problems I have had, have anything to do with burning DVDs. I have no problems there.

The main problem is with timer recording to the harddrive. Also one time it locked up in the navigation menu.
I do timer recorder to the HDD just about every day (and HS dub some of that to DVD's). I also use the Navigation menu routinely. It's not a firmware problem. My guess is that you've just got a flaky unit.
1 - 7 of 7 Posts
Not open for further replies.