AVS Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
192 Posts
Discussion Starter · #1 ·
I've had the Sceptre 30" monitor/HDTV for about a week now and have been playing with it and tweaking it. I am using it in my den as a computer monitor and as a second HD setup in my home. Considering the price from Costco, I am very happy with the performance/price tradeoff as compared to a more expensive LCD (Sharp, etc.).


I do have one issue that I am hoping to get some help on. I am using the DVI connection off of my Radeon 9800 pro card and am getting some noticeable flicker on the right side of the screen about 1/4 of the way into the screen from the right. It appears to be horizontal lines drawn very sporadically in a vertical band. These "flickers" are anywhere from 10 pixels wide to I would guess 100 pixels wide. They are only evident when I am on my desktop and worse when I have a window running a program open on the desktop. I have isolated the issue to DVI.


I have connected the computer via VGA (no problem), XBOX via component (no problem), etc. I've also tried two different DVI cables (one fairly generic and one a $70 Belkin Gold DVI cable).


I've got the most recent drivers for just about every piece of hardware in the computer, I've played with refresh rates. Am I missing something, or is there some other timing setting that I need to tweak? Any thoughts? Thanks in advance for any help that anyone can provide.


Computer specs;

ASUS A7N8X Deluxe Mobo

Athlon 2400+

1GB of 2700 RAM (two 512 sticks in Dual Channel Mode)

250GB Maxtor SATA drive

SB Audigy 2 sound card

Sony DVD+-RW drive

of course 128 MB Radeon 9800 Pro
 

·
Registered
Joined
·
2,127 Posts
This might sound crazy, but do you have another video card around that has the DVI port on it? Maybe of your closest friends do. If so, switch out the 9800 pro card and put that card in its place and see if you can isolate it to the 9800 pro card as opposed to the monitor DVI port. Here's hoping its the video card. Its a lot easier to replace than the 30" monitor.
 

·
Registered
Joined
·
192 Posts
Discussion Starter · #3 ·
Thanks for the idea. I swapped out my Radeon with an older GeForce Ti 4600 and am still getting the flicker.


I assume that this means that it is the DVI input on my monitor? Do I check it with another device like a HD set top box?


I've also played around with the resolution settings and apparently if I set the output for a non native resolution (1280x960) the flickering goes away. What gives?
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top