AVS Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
1,039 Posts
Discussion Starter · #1 ·
I have to give kudos for Panasonic for their support of the SS. I just got a demo unit for $99 about 3 weeks ago, but it died within about a week of bringing it home (HD ceased functioning). I called Panny and we did the quick diagnostic dance, and they determined it was dead. They arranged to have a refurbished one shipped to me. While the website says 24 hours, they said their float-stock was depleted and they said it would be more like 3 weeks (?!). Anyway, today, exactly 8 days after I called it in, the new SS showed up. Hell, they even included a roll of TAPE so I could seal the box and send it back to them. I was impressed. So, for a steal ($99 before rebate), I should have a nice new (okay, so it's refurbished, but it's better than the demo unit) SS.


I also called in about the guide problems many of us are having, and they walked me thru some steps to try and help (even though the unit was out of warranty). Very cool. So far, I'm happy with Panansonic's support of the Showstopper. Anyone else have good/bad experiences to share?
 

·
Registered
Joined
·
75 Posts
I was having dialing and connection problems with my Panasonic HS2000. Other than being on hold for 1/2 hour, had no problems with tech support and they had me up and connecting in that call. They were definitely on the higher end of the tech support scale. A nicer experience than most tech support calls I've made.
 

·
Registered
Joined
·
53 Posts
After almost a year of constant use, my 'select' button was giving out. I called Panasonic and they said they would replace it after I sent it in to them. Two days after I mailed mine out, I received a new one from them - Priority Mail. They didn't even wait for mine to arrive. (In the meantime, I just used the remote from my Replay.:D)
 

·
Registered
Joined
·
133 Posts
You guys were VERY lucky. Look around this forum and you will see many entries detailing horrid experiences with the Elgin repair center.


It took 10 weeks to get my system back and it had the same problem (bad drive). I had to send it in again and they said they had no parts. Finally got it back fixed. I immediately hacked it and put in a new drive - saved the original.



Greg
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top