AVS Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello Folks,


Just got the GE-610 I bought off of e-bay home (first ever projector for me). Still in the process of acquiring manuals. But could not resist...


Powered up the beast. The first time it came on and when I hit test buttono on the wired remote, it projected a grid (all three tubes working).


While I was messing around with the remote, I was trying to play with vertical and horizontal height adustments, the tubes shut off.


Now they will not come on. I powered cycled it a few times, but the tubes do not light up. The fans do come on.


waaaaa.


If this is deja vu all over again for any of you please share your experiences.


thx, Vinay
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #2 ·
I just remembered, the CRTs shut down while I was increasing the vertical size of the test pattern using the remote. If this is the cause, the remotes should be idiot proof. Any cures will be appreciated.


One other thing, the filament in the neck of the CRT is glowing. So there is power to the tubes.


Vinay
 

·
Registered
Joined
·
18,507 Posts
I generally do not give advice to people who snipe me in the last minute of bidding...:D :D


Just kidding, good score!


Do you hear the HV crackle when you turn on the set?


There are two LED's on the deflection board which is directly under the top cover. One LED indicates V fail, the other indicates H fail.


I have had the small trimpots on that deflection board go intermittent, causing hte set tpo think there is an H or V fail, and that then shuts the HV down.


I don't have the actual service manual or I'd be more specific, but others here on the forum do.


Don't dispair, this should be a relatively simple fix.


Curt
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Curt, hope your eye is OK and you are recuperating well. Ah, the e-bay bidding process. A few years ago I came to the realization that I have a gambling problem, so I never visit casinos. When on e-bay I get the exact same feeling of gambling. Either e-bay is novel idea for selling or some clever folks are truly making use of human psychology.


I did locate the two red leds (#s D020 and D023). During power up they each come on momentarily (in sequence) and then remain off.


Are they supposed to stay on to indicate normal operation?


Any basic checks I can perform without a service manual? I have meters and a 60MHz scope.


Also, they come on momentarily during shut down.


Thanks, Vinay
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top