AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
261 Posts
Discussion Starter · #1 ·
For the longest time--and after several forum posts on different forums--I was super frustrated with my HTPC. For no reason, my video would switch from 16:9 to 4:3 every time I turned off and on my TV. The only way to get it to display correctly was to minimize or close WMC so that the graphics car (or on-board video) would detect the desktop resolution.


So infuriating.


However, I finally came up with a great solution that is completely transparent. This, however, works with a Harmony remote, though I'm sure you could set up a script to detect a certain IR signal from a standard WMC remote.


What I did was set up my regular "Watch TV" activity with a new step and a new device. The device is the following when adding a new device:


Computer > Media Center PC > (Manufacturer) Microsoft > (Model) Windows Media Center SE


I then edited my current "Watch TV" activity to include the new device. In the settings, I added the following commands before the devices are turned off:


Microsoft Media Center PC: The remote pauses for 1000 milliseconds

followed by

Microsoft Media Center PC: "Alt-F4" command is sent to the Microsoft Media Center PC


What happened was the new device supports keyboard shortcuts. I sent the command to hit Alt+F4 which closes the current window (WMC) after a delay of 1 second. The delay is put in place so that you don't accidentally see the windows desktop when turning off the system--not that big a deal, it could just be a bit jarring.


The last thing to do is add a setting to "Watch TV" (if you already don't have one) that either starts up WMC or plays Live TV or whatever you want. That way you don't turn on the TV and see the desktop.


One issue I found is that if you are purposefully on the desktop and go to turn the power off, Alt+F4 will open a shutdown prompt. However, if this is ignored, your system will not shutdown. This will automatically fix itself the next time you choose the "Watch TV" activity. A positive side-effect (at least for me) is that WMC is not running when the TV is off. Not that this is normally a big deal, but for me, it's nice because I have Orb installed to watch Live TV on my phone and laptop. I normally would have to shutdown WMC through the Orb website, but this is no longer necessary!


Hopefully this helps a few of you who had a similar issue!
 

·
Registered
Joined
·
1,035 Posts
For me WMC7 would switch to 4:3 whenever I opened up the OSD for my receiver.


Keeping WMC7 in 4:3 I navigated to "Set up TV" and switched all the settings back to 16:9 1080P 59Hz. It has been working fine since.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top