AVS Forum banner
Status
Not open for further replies.
1 - 12 of 12 Posts

· Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
I bought a KDF42WE655 at Circuit City on Saturday. Got it home and set up that evening.


The picture was beautiful OOTB, made a few adjustments to color and sharpness, and enjoyed 3 days of great viewing.



I came home today, put a DVD in for my toddler, getting ready to make dinner and watch the NLCS, turned the TV on....


and nothing!


There are three lights on the front : Power/Standby, Timer, and Lamp.


When the unit is off, the Power/Standby is red. When you turn it on, it flashes green for a few seconds and then the picture fades in.


This time, the Power light flashes green for about a minute. The screen never initializes, and then the Power light goes to red and the Lamp light flashes red continually.


I've talked to Sony Service(outsourced), they had no answer. They read me the same script from their online Knowledge Base. I pushed and they sent me to second level service(U.S. this time). They had not had any reports of similar issues and said it would require in-home service.


Sony doesn't have any personnel in the Houston area, according to the rep, so he gave me the number to their "approved" service provider. I called that number, and of course it's not in service.


So...I called Circuit City. Seeing as how I purchased their 4-year extended warranty, I figured to get better service. I was sent to Service(outsourced again). They had no answers other than they could send a service tech Wednesday of next week. I pushed again and the supervisor there told me to call the store and they would replace my 4 day old TV.


I called the store, and of course the hourly employee told me they could replace it, but I would have to pay for the delivery. A nicely phrased request to the store manager took care of the delivery fee and it appears I will have a replacement this week.


Sorry, I had to vent as I have waited for over a year for the type of viewing experience I had for the past 3 days. This is just frustrating beyond belief.


Just one experience. Hopefully my next GWIV post will be better.
 

· Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
That seemed to be the response from the manager as well. I'm guessing the hourly employee may have been in CD's or something. :cool:


I'm dreading opening the new box and, voila, stuck pixels. Such is life.
 

· Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
True enough. The good news in the whole thing is that my wife and I absolutey love the experience and quality of HDTV in that format. We made a good choice it appears, but were given a bad apple. Circuit City will step up, I'm certain.
 

· Registered
Joined
·
8,927 Posts
Or that the GWIV TV’s have the same defective bulb problem that the GWIII’s had. How long do you think it will take before this thread reaches 120+ pages like the GWIII buzz thread did? My advice. Take the TV back and go and buy a GWIII for about a grand less. This way you know that the buzz problem has been fixed and you can get a free replacement bulb if the GWIII does have a problem.
 

· Registered
Joined
·
74 Posts
why would sony manufacture the GWIV with the same problems the GWIII had if they already realise it and have such begun manufacturing GWIII w/ the fix?


What kind of logic is this? It just makes you sound like a GWIII owner =\\


why all the gwiv hate?
 

· Registered
Joined
·
8,927 Posts
Because I do own a GWIII and I know how I was treated by Sony. There are plenty of reports of people still getting defective GWIIIs even 6 months after the problem was corrected.
 

· Registered
Joined
·
2,946 Posts
This certainly sounds like the GWIII bulb issue, with the lamp failing prematurely. If the set has otherwise been very good to you (no major geometry issues or stuck pixels), you'd probably be better off just getting the bulb / lamp replaced under warranty, rather than exchanging the entire set (i.e. better the devil you know than the one you don't).
 

· Moderator
Joined
·
2,436 Posts
1 - 12 of 12 Posts
Status
Not open for further replies.
Top