AVS Forum banner
1 - 20 of 44 Posts

·
Registered
Joined
·
1,622 Posts
Discussion Starter · #1 ·
Received an announcement today that Halcro USA is back in operation. Office is in Beverly Hills. The announcement indicates the company was purchased by a high end speaker company but will be doing business as a separate entity. Bruce B. is back as the Halcro USA President. Bruce Candy and Lance Hewitt are staying with the company "designing new products." (Gary and Paddy remain as well).



Jim
 

·
Registered
Joined
·
1,622 Posts
Discussion Starter · #3 ·
I think that's a fair question to ask given recent history. This is still a very small company and I'm unclear as to what level of backing they'll receive from this unnamed "high-end speaker company."


I guess it's good for all of us Halcro owners (and dealers), but remains to be seen what level of support is provided and what new products are introduced going forward. Personally, I still like the Halcro performance in my HT.



Jim
 

·
Registered
Joined
·
27,351 Posts
All is good!
 

·
Premium Member
Joined
·
5,275 Posts
halcro's main gig is metal detectors and landmine sensing devices as i recall. the audio is just a toy for the execs back when times were good.


paddy is a pretty cool guy i'm glad to seem him land on his feet.


now the 2 channel stuff sound pretty nice but big $$$ but this is the big balls forum of $20K+ !
 

·
Registered
Joined
·
1,622 Posts
Discussion Starter · #7 ·
I thougt Halcro Audio was always an audio company that had been bought by MineLab and was later separated from MineLab when the audio side slowed, which subsequently led to closing Halcro's US operation.



Jim
 

·
Registered
Joined
·
27,351 Posts
WhqWhhqtt are the main bugs you see? I see:


1. Switching sources with front panel knob is practically impossible.

2. Some sources fail to show the volume level on the front panel.

3. Pressing OSD interrupts the video while displaying info. Should just overlay the video.
 

·
Registered
Joined
·
213 Posts
I see all those, plus I also have problems with selecting source from remote. I sometimes have to push the button 2-3 times, especially if it's part of a macro. I am using Pronto, and never had this problem prior to last update.
 

·
Registered
Joined
·
27,351 Posts
I use RS-232 and that is problem free. You using IR?
 

·
Registered
Joined
·
27,351 Posts
RTI (poor man's Crestron). I am only using it as 1 way. But there is 2 way now. Best of all it is user programmable. If you got one, I'd send you my file and you'd be up and running.


I use a T4 remote in my theater and have a T3 in my family room. Easy to program and ultra reliable.
 

·
Registered
Joined
·
27,351 Posts
Also,


I checked with Gary a ways back. I have firmware #55 but there is a #57 that I have a copy of.. But with Halcro on shakey ground, I have not loaded it for fear of a failure. I don't think I need it as fore the most part all works fine.
 

·
Registered
Joined
·
560 Posts
I have all the same problems with the front knob and the IR remote. Switching sources is a pain in the butt.


Wanted to switch to RTI for RS232 but was told that RTI programming software not available to end users. Is this not correct?
 

·
Registered
Joined
·
27,351 Posts

Quote:
Originally Posted by Perfectionist2 /forum/post/16951352


I have all the same problems with the front knob and the IR remote. Switching sources is a pain in the butt.


Wanted to switch to RTI for RS232 but was told that RTI programming software not available to end users. Is this not correct?

Correct.... but it is available if you need it.
 

·
Registered
Joined
·
27,351 Posts
You know... I think you simply press and hold the POWER button on the front panel. If you want 57, I have it and the accompanying email and instructions..
 
1 - 20 of 44 Posts
Top