AVS Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
First off let me say 'hi' as this is my first post.. but enough of that. Let me tell you my story..


My neighbors up the street had a Bally Hang Glider Pinball which was restored and was placed in their family room. Fast forward 10 years, and because my neighbors are those type of people who buy things and let the fall into disuse, let the pinball machine fall into disuse as well. They put the poor thing outside.. in the rain.. until they decided to throw it out. This is where I come in. I was walking my dog around the block when I saw this thing.. it was that pinball machine I used to play at their house when I was in elementary school! So I called my friend with a pickup truck, and drove it down to my house. We rehooked up the scoreboard.. and what a mess :| It was in TERRIBLE condition. The scoreboard glass had been broken into 3 big pieces.. not that it mattered because it only had 15% of the silk screen art.. the wood had warped slightly over time.. and the outer shell had started to flake. A lot. It was so much as flaks, actually, as it was shingles.


We plug it in.. turn it on and.. it worked?? It worked! We played a few rounds, and delighted, we called it a night. We later replaced the thumper bumper skirts because the other ones we broken, and also replaced all the rubbers on the field.That was 1 year ago.. Now let me explain to you the condition it is in now.. how it got there.. I dunno..


The game, since we first got it, has been randomly choosing whether or not it is a 1 - 4 player game.. It started at 4.. then went down to 3... 2... back to 3.. then has been at a solid 1 for a while. The 1p score reel is on the fritz.. the 100 reel (second from the right)would stick in between 9/0 and would have to be gently pushed to the next number. Now it just spins uncontrollably if activated (which is quite often..). My 100 point thumpers.. which worked fine after replacing the skirts.. now don't register on the scoreboard. The 10 point one does.. but not 100. The bonuses given out at the end of the round would be endless.. but I found out why.. a blackwidow got in the way of the bonus mechanism and its guts were messing with the contacts >>. NOW today after doing some cleaning on the inside.. the game won't even start. I can turn on the machine.. but the start button won't work. I drop in a quarter.. just to see if the game decided to turn off free play and.. nope. The start button refuses to work



I am a pinball novice.. and am curious if anyone can help. If you need pictures to see what is truly going on.. just say the word. I am willing to do anything to save my pinball zombie.. Well, I am not going to take it in to a shop.. because they will just make me pay MORE than the machine is worth (and will be worth in a restored condition) to get it to work.


Thanks in advance..

actionDm425
 

·
Registered
Joined
·
2,926 Posts
Probably the best bet is to make a post on the rec.games.pinball group. There are a lot of guys there that can help repair and restore your game.


Good luck!
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top