AVS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·

Hi all :)

 

i recently bought a Harman Kardon AVR158. 

 

i hooked up my Wii-U, and set up the wii-u to surround.


The wii u is connected with a HDMI cable, and it transmits HD video and MULTICHANNEL PCM audio over this cable.


Now here's the problem...

If i set up the surround mode on my avr to "auto detect", it will switch to Dolby Pro Logic II Game.

You WOULD say that is ok, but it is NOT! I am missing channels on this mode, and i am not getting surround. If i hear correctly, i am missing the centre, surr R and surr L channel...

 

But!....

If i now toggle the "surround mode" button on the AVR, it will cycle trough the surround options wich then are manually selected. If i push the button often enough, it will come back to "auto detect", and NOW it will display "MULTICHAN. PCM", and i have perfect sound....

 

now... this should work, right?... NOT

If i now turn off my wii u, do something else, and later play again, the avr shows "Multichan. PCM" for a second, and then switches back to Dolby Pro Logic II Game!!!

And i loose the surround sound.....

AGAIN, if i toggle the "surround mode" switch, and again come back to "auto detect" (the mode it was on, and was selected the whole time", it goes to multichannel pcm again, and all is fine....

 

how can i get the damn thing to go to "MULTICHAN. PCM" all the time for this input??? (HDMI 3)

 

this is really anoying, especially because there is NO surround mode button on the remote.... but it should detect and switch by it self!!

 

Please advise!!!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·

nobody with some tips??


I am going to try a high speed hdmi 1.4 cable... Maybe that will do something.

Friend of mine (Harman Kardon seller) says the bandwith that the original cable can handle, could be a bit to small... so it cant detect the signal like it should...
 

·
Registered
Joined
·
12,233 Posts
Its not the cable...

Check page 20 of the Operation Guide this explains how to select the Surround mode by input..


Just my $0.05... 👍😉
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Did that. Can you see "multichan. PCM" in there?


Its not there in manual mode!


Only in auto mode, and only when i cycle thru the modes....


In the manual i cant even find something about the "multichan. PCM" mode :s


So i cant set the mode to "multichan. PCM" manually for that input! That's the whole problem



EDIT: The "multichan. PCM" setting is not even mentioned on page 30 (table)...

but spoken of on page 21 where the compatible input streams are mentioned:
Quote:
digital formats include dolby digital 2.0 (two channels only), dolby digital 5.1, dolby

digital ex (6.1), dolby digital plus (7.1), dolby truehd (7.1), dtS-hd high-resolution

Audio (7.1), dtS-hd Master Audio (7.1), dtS 5.1, dtS 96/24 (5.1), two-channel pcM

modes in 32khz, 44.1khz, 48khz or 96khz, and 5.1 or 7.1 multichannel pcM. (Your

AVr will downmix the discrete surround back-channel information in 6.1-channel and

7.1-channel recordings into your system’s surround left and surround right channels.)
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Ok, so it SHOULD work, but it does not.


I have sent the avr to the service centre, they replaced the only thing that could have an effect on detecting the audio stream, and that did nog help.


They did some further tests and research, and the problrm is located in the firmware.


Contacted harman kardon and they refuse to do something about this.


The service centre also tested other avrs from harman kardon, and the 161 worked perfectly. So they traded my 158 for the 161!

Perfect service, and the 161 is a super avr!
 
1 - 5 of 5 Posts
Top