AVS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3,039 Posts
Discussion Starter · #1 ·
Seriously...


I sent this to get fixed once and it came back perfect. Now I have another green blob in the middle of my screen!


I hate this!
 

·
Registered
Joined
·
617 Posts

Quote:
Originally Posted by bgillyjcu /forum/post/18134164


Seriously...


I sent this to get fixed once and it came back perfect. Now I have another green blob in the middle of my screen!


I hate this!

Don't feel bad I've sent mine in twice, last time was 3 months ago. They always do a good job. But warranty ran in middle of Jan. have to see how much it will cost next time.


mark
 

·
Registered
Joined
·
3,039 Posts
Discussion Starter · #3 ·
Mine is now out of warranty too.


I tried to take it apart, but I quit for fear of breaking it.


I guess I'll have to live with the nice green blob in the middle of the screen. Just will have to stay away from DARK movies...on a black screen shot it is so clear...
 

·
Registered
Joined
·
617 Posts

Quote:
Originally Posted by bgillyjcu /forum/post/18142166


Mine is now out of warranty too.


I tried to take it apart, but I quit for fear of breaking it.


I guess I'll have to live with the nice green blob in the middle of the screen. Just will have to stay away from DARK movies...on a black screen shot it is so clear...

Did you call them to find out how much more than the $60 it was to clean it?


mark
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top