AVS Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
620 Posts
Discussion Starter · #1 ·
Got my new Silicon Dust HDHomeRun yesterday and got it all set up.


Quick TV works FINE but when I try to use Media Center, The video looks fine, the audio loops for a while and then I get the following error:

Quote:
Video Error

Files needed to display video are not installed or are not working correctly. Restart window media center or restart the computer.
I did a test recording and that worked out fine too...played back fine in WMP as well as TMT5 but since we've now told DirecTV goodbye, I want this to be easy enough for my wife and kids to use.


I did a search and found the following thread and a possible solution in the last post:

http://www.avsforum.com/avs-vb/showthread.php?t=1169117


I'm gonna try that when I get home but wanted to ask if any of the rest of the HDHomeRun community has seen similar problems and what they did to get it fixed.
 

·
Registered
Joined
·
2,321 Posts
When I get that message I turn the AVR off and then turn it back on. Then I close media center and restart it. Try this or something similar.


I think it is related to DCHP, the protected audio rules. It is a PITA.
 

·
Registered
Joined
·
620 Posts
Discussion Starter · #3 ·
Quote:
Originally Posted by Postmoderndesign
When I get that message I turn the AVR off and then turn it back on. Then I close media center and restart it. Try this or something similar.


I think it is related to DCHP, the protected audio rules. It is a PITA.
Thanks for the suggestion...
 

·
Registered
Joined
·
620 Posts
Discussion Starter · #4 ·
Quote:
I simply disabled Dolby Digital processing within Media Center by browsing to Tasks --> Settings --> TV --> Audio and setting it to equalize the audio volume by clicking that checkbox. As soon as that box is checked, and Media Center is restarted, the TV playback works fine.
So...this is what I did and it seems to have worked fine...
 

·
Registered
Joined
·
184 Posts
Go to Settings > General > Visual and Sound Effects and uncheck "Play sounds when navigating Windows Media Center" if you haven't. That should fix the problem.. I think there may be other causes for that message though.
 

·
Registered
Joined
·
1,016 Posts
Here is the solution:


In your windows sound setting set the number of speakers to 2.0 (even if you have 5.1/7.1). The reason this won't matter for WMC or other media players if you're using hdmi for bitstreaming is that it'll still send the signal in full 5.1/7.1 glory down the wire. This won't work if you're using analog audio cables.
 

·
Registered
Joined
·
147 Posts
Regarding the problem above.


If I go to Tasks --> Settings --> TV --> Audio -->Audio Equalize and turn it off, I get the video error. Does everyone get this on WMC7 or is it just with the HDHRP - WMC pairing? I can select 5.1 speakers in General > Setup, but the sound check doesn't work anymore after dinking around with this. Very strange. While I now know how to avoid this bug is WMC still bitstreaming if I have my HDMI>AVR selected in the control panel as default audio device? So is this a widely known bug or system specific?


I am not getting Dolby Digital off out of my HTPC Live TV possibly because I don't have a cable M-card yet (Comcast) and am just getting clear QAM channels and PCM?
 

·
Registered
Joined
·
3,121 Posts
You should be able to get Dolby Digital from clear QAM. I do all the time with a non-cablecard tuner, at least. Usually the networks are DD.
 

·
Registered
Joined
·
83 Posts
I had this issue if I set my speakers to 5.1 and then set WMC to 5.1 bitstream as well. The issues seems to be if you want WMC to bitstream the Dolby tracks in HD tv streams and have windows audio set to 5.1. I found that if I set WMC to not bitstream Dolby live tv would play fine bu I would only get audio out of the L and R channels. I then found out if I disabled the exclusive settings in the sound card settings I would get 5.1 pcm out of live tv but in TMT5 I couldn't bitstream audio. I finally found a solution on TGB before it changed over and it solved all of my issues.


In the settings for your sound card set audio to 7.1 ( Even if you have 5.1 ) and then disable the left and right surround speakers ( Not the front L and R channels ). So you have your audio set to 7.1 but set it to work with 5.1 speakers. Go into WMC and set audio to bitstream and everything will now work correctly. Dolby bitstream in livetv, 5.1 pcm audio in windows for games, bitstreaming in TMT5 ( You can leave exclusive mode on ) and everything works smoothly.


I don't know why this works but this works on all three of my HTPCs and I hope it works for you as well.
 

·
Registered
Joined
·
147 Posts
Thanks, I'll try this tonight.


BTW. What I see in my sound devices are the onboard RealTec sound and the Receiver (Marantz 5006). The driver for the Receiver (Display) is listed as the Intel Audio Display. If I use the on board RealTec, there is no sound in digitial. Maybe I will also try optical?
 

·
Registered
Joined
·
147 Posts

Quote:
Originally Posted by jskube84 /forum/post/21059975


I had this issue if I set my speakers to 5.1 and then set WMC to 5.1 bitstream as well. The issues seems to be if you want WMC to bitstream the Dolby tracks in HD tv streams and have windows audio set to 5.1. I found that if I set WMC to not bitstream Dolby live tv would play fine bu I would only get audio out of the L and R channels. I then found out if I disabled the exclusive settings in the sound card settings I would get 5.1 pcm out of live tv but in TMT5 I couldn't bitstream audio. I finally found a solution on TGB before it changed over and it solved all of my issues.


In the settings for your sound card set audio to 7.1 ( Even if you have 5.1 ) and then disable the left and right surround speakers ( Not the front L and R channels ). So you have your audio set to 7.1 but set it to work with 5.1 speakers. Go into WMC and set audio to bitstream and everything will now work correctly. Dolby bitstream in livetv, 5.1 pcm audio in windows for games, bitstreaming in TMT5 ( You can leave exclusive mode on ) and everything works smoothly.


I don't know why this works but this works on all three of my HTPCs and I hope it works for you as well.

This seems to have worked? I haven't analyzed the sound yet with different sources but at least I'm getting the center channel and the speaker tests seem to work correctly. But where in the WMC menu is the bitstream selection? All I see is analog under audio unless I select secondary SAP which doesn't work. But again, Tasks --> Settings --> TV --> Audio --> Auto unchecked srcews things up. Auto must be checked. Does this mess up Dolby Dig as it says? OR should I just ignore everything in WMC? Also, in the Control Panel sound device settings. Do I allow programs to take control? I'm not sure I want WMC to take control....


BTW I am outputting thru HDMI. Would I have the same issues if I used optical out?


Does anyone know if this issue is common for WMC or somehow just due to a hardware pairing (HDHRP) or a particular HDMI handshake issue with some receivers?


Thanks for the help. I'm on the right track in that at least I'm getting output to all speakers and I'll test more later.
 

·
Registered
Joined
·
83 Posts

Quote:
Originally Posted by ckensto /forum/post/21060640


This seems to have worked? I haven't analyzed the sound yet with different sources but at least I'm getting the center channel and the speaker tests seem to work correctly. But where in the WMC menu is the bitstream selection? All I see is analog under audio unless I select secondary SAP which doesn't work. But again, Tasks --> Settings --> TV --> Audio --> Auto unchecked srcews things up. Auto must be checked. Does this mess up Dolby Dig as it says? OR should I just ignore everything in WMC? Also, in the Control Panel sound device settings. Do I allow programs to take control? I'm not sure I want WMC to take control....


BTW I am outputting thru HDMI. Would I have the same issues if I used optical out?


Does anyone know if this issue is common for WMC or somehow just due to a hardware pairing (HDHRP) or a particular HDMI handshake issue with some receivers?


Thanks for the help. I'm on the right track in that at least I'm getting output to all speakers and I'll test more later.

I'm sorry I should be more specific when I talk about audio inside of WMC. If you set audio normalization to on it will send PCM and if you set it to off WMC will bitstream the audio. So for bitstream set audio normalization off and for PCM set audio normalization to on.
 

·
Registered
Joined
·
147 Posts

Quote:
Originally Posted by jskube84 /forum/post/21061111


I'm sorry I should be more specific when I talk about audio inside of WMC. If you set audio normalization to on it will send PCM and if you set it to off WMC will bitstream the audio. So for bitstream set audio normalization off and for PCM set audio normalization to on.

Thanks again, jskube84. Very helpful. Audio equalization screws me up UNLESS in Device Properties Exclusive modes and I uncheck letting programs take control? This seems to be the key to avoid the Video error. Not letting WMC take control. I can use normal 5.1 settings now without using 7.1 and disabling the side speakers and it works. But I am not hearing the center channel on some stations and even ones that I do get surround on I am only getting PCM from my clear QAM channels maybe it depends on the program?. Also, shouldn't I see something other than Analog and the Dolby Decoder Settings are grayed out. Again though I'm wondering if this is due to the fact that I'm not using and M-card yet and just getting clear-QAM. Also, maybe I should now run WMC set up for the Tuner all over again.
 

·
Registered
Joined
·
83 Posts

Quote:
Originally Posted by ckensto /forum/post/21061226


Audio normalization screws me up no matter what, even after going thru the 7.1 workaround. Do I need to disable the exclusive modes and not let programs take over? I'll play around with that next.

Nope, you can leave exclusive mode on.
 

·
Registered
Joined
·
147 Posts
Like you said, exclusive mode give the "video error" unless I use the 7.1 work around. I'll do more sound analysis later but it seems I should see more than Analog and should be able to check the Dolby Decoder settings if everything was working totally correctly in the TV audio menu.
 

·
Registered
Joined
·
83 Posts

Quote:
Originally Posted by ckensto /forum/post/21061641


Like you said, exclusive mode give the "video error" unless I use the 7.1 work around. I'll do more sound analysis later but it seems I should see more than Analog and should be able to check the Dolby Decoder settings if everything was working totally correctly in the TV audio menu.

On 2 out of my 3 HTPCs I have the audio set to stereo because I bitstream everything and have no need for PCM audio. I have to use the 7.1 workaround for my downstairs pc because I play some games on it and like having surround sound for my games ( which use pcm ). The 7.1 workaround is weird but it def. works for me.
 

·
Registered
Joined
·
147 Posts
Tonight I'll try setting up the tuners again with the 7.1 work around just to see if anything changes in the TV>Audio menu. I am getting multichannel for some programming, but not all and the fact that I see Analog and the Dolby Decoders are grayed out makes me wonder.


BTW. It may be that it doesn't matter 7.1 or stereo as long as its different than WMC. I found this. Same issue.

http://www.silicondust.com/forum/vie...lled+correctly on the SiliconDust forum.


I'm spending waaaaaaaaayyyyy too much time on this. I wish I had found the work around earlier!
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top