AVS Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I recently purchased a new IBRA High Speed HDMI Cable (HDMI ver. 1.4) to go with my 4k TV and my 4k upscaling blu-ray player. However, since I have installed it I have noticed that other devices that are connected to my tv using older cables are beginning to cut out.

My PS4 has started to cut out intermittently - the screen will go black for a second or two and then the input label will appear on the screen as though a device has just been detected on start up. The same thing is happening with my Apple TV as well. It is not happening on the blu ray player however (which the cable is attached to).

I tried replacing the cables on the faulty devices but the same thing kept happening so I tried the setup without the new cable attached and now everything is working fine again. Has anyone encountered anything like this before? It is as though the new cable is causing other cables to lose their connections.

Thank you.
 

·
Registered
Joined
·
18,854 Posts
There is no such thing as an HDMI 1.4 cable. The 1.4 is the hardware specification, not the cable specification. If the cable you bought is labeled as an "HDMI 1.4" cable, then it's questionable as to what that cable actually is. There are only two types of HDMI cables, standard and high speed. And of the high speed, the cable can be either passive or active (requires some sort of power source). Current, passive high speed HDMI cables (preferably certified) are more than adequate. I've never heard of an HDMI cable affecting the performance of another cable but I suppose anything is possible.

Why don't you explain your setup in a little more detail.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
My apologies for the lack of technical knowledge aha, I'm at the end of my tether both mentally and technically over this issue. My setup is fairly standard - 40" television with 3 devices all attached via hdmi (Blu Ray player, PS4 and Apple TV in ports 1-3 respectively) and a sound bar attached via optical. As far as I have ever been aware all but 1 of the cables is high speed (the cable in question was to replace to older inferior cable).

I've never had any problems until plugging in this new cable, but 10 minutes after plugging it in things start to go wrong. Now, the cable was attached to the Blu Ray player and it worked perfectly fine but when I started to play a game on the PS4 I noticed that the screen turned black for a second or two and 'HDMI 2' appeared at the top of the screen, as it does whenever the tv detects a signal when a device is turned on. It then continued doing this on both the PS4 and the Apple TV. Sometimes it only happened once every 5-10 minutes, then it might happen 5 times in 30 seconds. I tried changing the ports, changing the cables with other around the house, I tried resetting all of the devices individually but it still seemed to happen. So I tried unplugging the new cable and plugging the old one back in (which was earlier this morning) and I've had no problem with it. Now I assume it's the cable, but my concern is that it might be the hardware and any other cable I purchase may have the same issue.
 

·
Registered
Joined
·
22,643 Posts
If all works well, use the old cable and try to get a refund on the new cable. Or... trash it. ;)
 

·
Registered
Joined
·
2,990 Posts
Not sure I follow the logic - you have a working system, you purchase/install a badly labelled cable, the system goes nuts and it's everything but the cable causing the problem :)

There are lots of badly made cables on the market.

Hopefully you can return the cable for a refund!

Joe

PS Always ensure all devices are powered off at the wall when plugging/unplugging HDMI cables.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Now that you put it like that I realise I've been worrying about the wrong thing - I just couldn't make sense of what was happening so I assumed the worst. Thanks for putting up with the newbie! I'll return it for a refund post haste.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top