AVS Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5,101 Posts
Discussion Starter · #1 ·
Well I just got my monoprice switch and toshiba a1, taking a risk everything works fine with the monoprice hdmi switch, except my new A1, for a second the display simply says, hdmi, no link!?!


I dont know what this means, but Im guessing my next step now will have to be to try the port savers, and hope that works, any other suggestions?
 

·
Registered
Joined
·
5,101 Posts
Discussion Starter · #3 ·
I should also mention my connection is a 3 foot monster hdmi cable to the switch, and then a 30 foot dvi cable with hdmi adapters on both ends, I had originally ran dvi cable through my ceiling with my original projector 2 years ago.
 

·
Registered
Joined
·
5,101 Posts
Discussion Starter · #4 ·
I guess I can try direct display, the trouble is with a 3 foot hdmi cable and a projector, i dont know how im gonna hook it up right into the projector.


Also power cycling display? Im not sure what you mean?
 

·
Registered
Joined
·
1,888 Posts
You may be experiencing handshake issues with your components. Turn on your Projector first and select the HDMI input. Next the HD player then press V output on your remote, you should see HDMI on the player's display. HDMI has to be selected before it will work. Hope that helps.
 

·
Registered
Joined
·
5,101 Posts
Discussion Starter · #6 ·
Problem solved, it was an hdmi adapter going to the projector, luckely while I needed one for my pc, it was not as picky, swapped the one for my pc, and put the pc one on the end going to my projector which was brand new, and now the hd-a1 works no problems.


Everything works great; Can switch inputs no problem, only issue now is I have to update the firmware, when purchased I was told it was 2.0 but I believe it is not since I get an error when playing king kong.


How do I check what firmware I have?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top