AVS Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Hi guys, i have a samsung tv model UN46EH6030, and always used it with my gtx 660ti card. this week solving a youtube problem i noticed a setting called Dinamic interval, and there is 0-255 and 16-235. i selected 0-255 setting and did this test http://www.lagom.nl/lcd-test/black.php
o noticed that i just can see after the nuber 25 square. i am using my tv in pc mode, and there is a setting called hdmi black level that was set to low, when i put to normal i notice a little washed out image but i can clearly see every square on the same test.
when i set to 16-235 again with black levels normal the image is all washed out with blacks on the page now being grey, but when i set back to low blacks that was my initial setting i start seeing the squares after number 8. so what should be the best setting?
1)full rgb+normal black=bit washed out but pass on test
2)limited rgb+low black=very good contrast but do not pass on test (just see the square after number 8)

btw i am using through hdmi directly to my tv from gtx 660ti.
thanks in advance.
 

·
Registered
Joined
·
909 Posts
squares after number 8. so what should be the best setting?
1)full rgb+normal black=bit washed out but pass on test
2)limited rgb+low black=very good contrast but do not pass on test (just see the square after number
This will help hopefully explain what is happening when you select Limited/Full, some manufacturers have these name differently though.


No, I mean 0-255 for the GPU, video player and display. But setting everything to 16-235 will be essentially the same. I'm against setting everything to 16-235 because then there's extra conversions. AFAIK, there aren't any GPUs that can output native 16-235 and 16-235 will always get expanded to 0-255 regardless, so setting everything to 16-235 will cause the GPU to scale up to 0-255, then back down to 16-235. Setting the player to output 0-255 will avoid this extra step. The only benefit to ttnuagmada's setup, is that you can see BTB/WTW detail, but the downside is that you clip levels below 16 and above 235 in the desktop.

Setup 1 (my setup):
GPU outputs 0-255
Video player outputs 0-255
Display expects 0-255
Desktop and videos have matched levels where 0 is black and 255 is white, and the display is expecting this range. Videos get expanded from 16-235 to 0-255 once. The desktop gets no conversion because the GPU is outputting native 0-255.


Setup 2:
GPU outputs 16-235
Video player outputs 16-235
Display expects 16-235
Again, desktop and videos have matched levels and the display is expecting a range of 16-235 where 16 is black and 235 is white. Videos get expanded from 16-235 to 0-255, then back down to 16-235. The GPU converts 0-255 to 16-235 for the desktop. Result looks essentially the same as setup 1, but with more conversions.

Setup 3 (ttnuagmada's setup):
GPU outputs 0-255
Video player outputs 16-235
Display expects 16-235
Now the display expects a range of 16-235, but the desktop is outputting 0-255. So videos will look right, but the desktop will clip levels below 16 and above 235. Again, this is the only way to be able to see WTW/BTB detail on a computer.
 

·
Registered
Joined
·
487 Posts
On Samsung TV's, black level "Normal=Full RGB", "Low=limited 16-235". If you set the TV to Normal(full), then your other devices need to also be set to Full.
 

·
Registered
Joined
·
909 Posts
The RGB range maps black/white to either 0/255 or 16/235. If your levels don't match, blacks either won't be black, or you'll clip black detail. If all of your devices and display are on the same page, black/white will be mapped the same on all devices and your display will expect black and white to be where they should be.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5
thank you guys for the anwers. i set the nvidia driver to 0-255, and set the tv to hdmi level=normal. it passes all rgb tests, showing all squares, but now everything looks washed out, every youtube video. maybe is just me not used to this setup, because before it had punchy blacks and a image with very good contrast. games are washed out too. i entered vimeo just to test this setup and this video https://vimeo.com/channels/staffpicks/124307250 i suppose it should be black around the girl, and is gray, also in red part is not a very bright red.
also i tested a movie in mpc, with madvr output to 0-255, and my setup always was to madvr change to 24p and tv auto change to a calibrated movie mode, and with 16-235 the movie looks like that have more contrast and better blacks.
so is something wrong or is just me not used to this setup?
 

·
Registered
Joined
·
909 Posts
but now everything looks washed out, every youtube video. maybe is just me not used to this setup, because before it had punchy blacks and a image with very good contrast. games are washed out too. i entered vimeo just to test this setup and this video https://vimeo.com/channels/staffpicks/124307250 i suppose it should be black around the girl, and is gray, also in red part is not a very bright red.
also i tested a movie in mpc, with madvr output to 0-255, and my setup always was to madvr change to 24p and tv auto change to a calibrated movie mode, and with 16-235 the movie looks like that have more contrast and better blacks.
so is something wrong or is just me not used to this setup?
There could be a levels mismatch, from what I gather from the three different PC setups mentioned in the examples above that I quoted from another thread. Your "best" path is GPU 0-255, TV 0-255, Video Player 0-255. whether this is Normal , or Limited, sometimes these two can be miss labeled.

HDMI level normal on the this TV is what? 0-255 or 16-235? I don't own a Samsung so I am not sure about this. If it looks washed out as you are describing then this is the other thing to try. Do you have a setting in the menus called Black Level. I have this setting on my Panasonic ST60 and it has two options, Light or Dark. When I set this to Dark on my TV and I am viewing video levels 16-235 say Blu-ray as the source just for example will crush blacks, Light is the correct setting in this case. Maybe this particular setting in your PC mode is not set correctly corresponding to the rest of the HDMI Normal setting you are using.

On a black clipping pattern like the one off of the AVS HD 709 disk what does your black level look like? pattern 16 should be invisible and 17 and up should be visible. Make sure nothing below 16 is visible including 16. Check this in your PC Mode, so download the appropriate AVS HD 709 file.
http://www.avsforum.com/forum/139-display-calibration/948496-avs-hd-709-blu-ray-mp4-calibration.html

The MP4 version is the one you want. The AVCHD version is to have a disk made to play on a blu-ray player.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #7 (Edited)
There could be a levels mismatch, HDMI level normal on the TV is what? 0-255 or 16-235? I don't own a Samsung so I am not sure about this. If it looks washed out as you are describing then this is a mismatch of video levels from PC levels. Video is 16-235 but PC is 0-255.
hdmi level normal the imagem become clearer and washed out, hdmi level low the image become darker and with more contrast.
when i set hdmi low and put 0-255 on nvidia panel the image becomes darker but i think black levels are crushed, youtube player becomes black instead of grey.
EDIT:the name of setting is hdmi black level and there just two options, low and normal.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #8
There could be a levels mismatch, from what I gather from the three different PC setups mentioned in the examples above that I quoted from another thread. Your "best" path is GPU 0-255, TV 0-255, Video Player 0-255. whether this is Normal , or Limited, sometimes these two can be miss labeled.

HDMI level normal on the this TV is what? 0-255 or 16-235? I don't own a Samsung so I am not sure about this. If it looks washed out as you are describing then this is the other thing to try. Do you have a setting in the menus called Black Level. I have this setting on my Panasonic ST60 and it has two options, Light or Dark. When I set this to Dark on my TV and I am viewing video levels 16-235 say Blu-ray as the source just for example will crush blacks, Light is the correct setting in this case. Maybe this particular setting in your PC mode is not set correctly corresponding to the rest of the HDMI Normal setting you are using.

On a black clipping pattern like the one off of the AVS HD 709 disk what does your black level look like? pattern 16 should be invisible and 17 and up should be visible. Make sure nothing below 16 is visible including 16. Check this in your PC Mode, so download the appropriate AVS HD 709 file.
http://www.avsforum.com/forum/139-display-calibration/948496-avs-hd-709-blu-ray-mp4-calibration.html

The MP4 version is the one you want. The AVCHD version is to have a disk made to play on a blu-ray player.
Did the black clipping test,
in 16-235, hdmi level low, madvr 16-235=levels 9 and up are visible
in 16-235, hdmi level low, madvr 0-255=levels 24 and up are visible
in 0-255, hdmi level normal, madvr 0-255=levels 17 and up are visible
in 0-255, hdmi level normal, madvr 16-235=all levels visible
 

·
Registered
Joined
·
909 Posts
Did the black clipping test,
in 16-235, hdmi level low, madvr 16-235=levels 9 and up are visible
in 16-235, hdmi level low, madvr 0-255=levels 24 and up are visible
in 0-255, hdmi level normal, madvr 0-255=levels 17 and up are visible
in 0-255, hdmi level normal, madvr 16-235=all levels visible
So let's sort this out, cause I think I am getting confused in all this. HDMI Normal on your TV is 0-255 which is PC Levels, So that means that HDMI Low is 16-235 which is video levels. In this case I think you want to set you configuration up like this In 0-255, HDMI Level Normal, Madvr 16-235 all levels visible . Then you will have to adjust your Brightness control on the TV so that 17 is visible and 16 and below is invisible.
 

·
Registered
Joined
·
6,804 Posts
My setup for madVR playback:

madVR 16-235
GPU 0-255 (passthru)
Display RGB low (video levels)

This is recommended if all you are doing is video playback using madVR.

If you want the desktop to match levels as well, which are always 0-255 do this:

madVR 0-255
GPU 0-255 (passthru)
Display RGB normal (full range)

or

madVR 0-255
GPU 16-235 (video scaling)
Display RGB low (video levels)

The first would be preferred because the second will scale full range from madVR to video range in the GPU and possibly cause banding.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #11
So let's sort this out, cause I think I am getting confused in all this. HDMI Normal on your TV is 0-255 which is PC Levels, So that means that HDMI Low is 16-235 which is video levels. In this case I think you want to set you configuration up like this In 0-255, HDMI Level Normal, Madvr 16-235 all levels visible . Then you will have to adjust your Brightness control on the TV so that 17 is visible and 16 and below is invisible.
I did this and in media player classic using madvr i see level 17 and above flashing after decreasing the brightness of tv, but outside mpc i think the image is not correct. in this test http://www.lagom.nl/lcd-test/black.php i just can see the squares 20 and above.

My setup for madVR playback:

madVR 16-235
GPU 0-255 (passthru)
Display RGB low (video levels)

This is recommended if all you are doing is video playback using madVR.

If you want the desktop to match levels as well, which are always 0-255 do this:

madVR 0-255
GPU 0-255 (passthru)
Display RGB normal (full range)

or

madVR 0-255
GPU 16-235 (video scaling)
Display RGB low (video levels)

The first would be preferred because the second will scale full range from madVR to video range in the GPU and possibly cause banding.
I set up gpu to full rgb, madvr to full rgb and tv to full rgb. i can see all squares in this test http://www.lagom.nl/lcd-test/black.php and in black clipping test in avs hd709 i can see bars 17 and above. i still think the image is washed out but i think that i was really used to the crushed blacks before.
one thing i noticed that nvidia driver was always using full rgb when i was playing video with madvr because of refresh rate change from madvr.
so if in black clipping test and another black level tests, if i can see all squares or flashing lines everything is alright and i don't have to look back for previous setting?
in my htpc i use windows normally in PC mode and when i put a movie in mpc with madvr it changes the refresh to ~23.976hz and tv automatically change to movie mode that was a bit tweaked by me following a brazilian forum of owners of my tv model. but if i try to put movie mode and use windows it is so wrong, colors are more warm and everything is not quite right like a monitor, but in PC mode is like a giant monitor with correct colors and everything, why is this? if movie mode is the correct calibrated one why can't i use it in windows normally?
 
1 - 11 of 11 Posts
Top