AVS Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter · #1 ·
Hi,


i am currently running a passive cooled P3-500 as my HTPC with 512mb ram and a 7200 rpm hdd, along with an ATI rage fury 128 pro.


DVD's look nothing short of superb with power dvd xp, the problem is when using Dscaler the picture is jerky (although the quality is excellent) this is only noticable in fast scenes and gets less aparent with differnt de-interlacing options enabled, really i need some tips on the lest cpu intensive settings as this p3-500 doesnt seem to be able to quite cut it :( the problem is that this is as fast as i can get passive cooled and i dont really want to upgrade the HTPC :/


Cheers :)
 

·
Registered
Joined
·
923 Posts
What are you using DScaler for? DVD? Console Games? LD? VHS? TV?


First off, before you start up DScaler, do a Ctrl+Alt+Del and End Task everything except Explorer and SysTray. That'll free up a bunch of system resources. Then inside DScaler, turn off Auto Detect Film Mode, Fall Back to Video on Bad Pulldown and JudderTerminator, if you have them on (assuming you're not using this to watch films). HM Greedy is going to be your best deinterlace method, but its also pretty much the toughest on your machine. Try dropping back to one of the 2-Frame modes to get decent quality and give your CPU a bit of breathing room. Also, you can get some overhead back by lowering your pixel width (this does directly effect your PQ, though) and by minimizing your filter use (turn them all off; go into Advanced Video Flags and start unchecking things, one at a time starting from the bottom up and see if turning any of them off effect the PQ in any way that you consider bad, leaving only the ones that are absolutely necessary checked).


Hopefully a combination of some of those things should give you optimum PQ without droping frames.


Good luck,

Kensai
 

·
Registered
Joined
·
1,755 Posts
I've been doing thread searches recently on running dscaler on "lower powered" CPUs without dropping frames (jerking and text bobbing). The same suggestions appear in most of these threads (SleepInterval=0... BackBuffers=2... turn-off filters... plus the stuff listed in the above post). The 2 cpu preformance "enhancing" tweaks I've recently found are never mentioned. These tweaks are: set bHurryWhenLate=1... and... WaitFor Flip=0

Now I did find a referrence to "set Hurry_When_Late=0" but that seems like the wrong setting for a slow machine...you'd think you'd want to turn that option ON. I realize that both of these tweaks will cause some sort of PQ degradation but it sure seems to "beat the hell out of" the jerky/stuttering/bobbing motion thing. In fact, I can seem to do GreedyHM with all the advanced options turned on (except Auto Pull-Down) at 754 pixel width sampling, with all the Auto-"everything elses" and filters turned ON on a lowly little 650MHz AMD with no stuttering. (The easiest way to check for this is to tune in to MSNBC and watch the motion of the headline ticker-tape at the bottom of the screen.) True, there is some kind of a PQ penalty to be had by hurrying the CPU along alittle but my eyeballs don't seem to be calibrated to the point of noticing it. So if you have a slow CPU why not give these 2 tweaks a try? Hey, you can always set them back if you think the picture sucks.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top